In core upgrader, replace the hard-coded required PHP/MySQL versions
|Reported by:||nacin||Owned by:||dd32|
|Severity:||normal||Keywords:||has-patch commit early|
Related: #11464... This originated there.
wp-admin/includes/update-core.php, which gets copied over after download during an upgrade, has a new check in 2.9 to ensure that the MySQL and PHP versions are what is required by the downloaded version.
Originally, a patch was committed that pulled in the downloaded version.php file to check what the new version required. (That patch also added the $required_mysql_version and $required_php_version globals.)
This part got reverted because the include path wasn't right (and only coincidentally correct on the systems it was tested on before commit), and so for 2.9 the values were hard-coded.
Attached is a patch that gets it right. It has been tested on an environment that would have failed the first time around.
I have also attached a separate diff that includes the core hacks required to test this, as otherwise the downloaded update-core.php will replace your patched update-core.php.
This patch fixes #11638 as well, but that fix belongs in 2.9.1.
Change History (21)
comment:14 nacin — 18 months ago
- Milestone Future Release deleted
- Resolution set to maybelater
- Status changed from new to closed
comment:16 dd32 — 14 months ago
- Milestone set to 3.5
- Resolution maybelater deleted
- Status changed from closed to reopened