Deprecate in_category in favor of has_category
|Reported by:||Otto42||Owned by:|
#12526 introduced has_category. There was some patches there which did and did not deprecate in_category.
End result is that they're now both in category-template.php, doing the exact same thing (serving as a wrapper to has_term).
I think we need some naming consistency here. Deprecate one or the other of them in 3.2, perhaps.