Opened 15 months ago
unify function naming convention get_ vs. the_
|Reported by:||thomask||Owned by:|
even after about 400 custom wordpress instalation i always got problem remembering the proper name of many functions, if they are returning the content or echoing it.
Most of the functions got get_something() and the_something() but some functions got get_the_something() (e.g. get_the_post_thumbnail) and some got the_something(echo=false) or something(echo=true) etc.
It would be nice if we would consolidate the naming convention (IMO get_ and the_ would be the best) and make current functions obsolete.