replace the filter 'use_http_extension_transport' with 'use_exthttp_transport'
|Reported by:||DD32||Owned by:|
The filter to disable the PHP HTTP Extension differs in naming from the rest of the filters, This makes it slightly awkward for plugins to manage the enabling/disabling due to the filters name differing from the class name, Ignoring the fact that plugins can work around it, It seems worthy that such a change should be made to at least bring consistency.
The attached patch depreciates the current filter name, and introduces the new. The current filter continues to work via a depreciated function hook, I dont think removing it entirely would be appreciated, And whilst it could just use 2 apply_filter() calls in the HTTP class, This seemed a better option.
Note: Theres no function to mark a filter as depreciated, i guess they've generally just been removed..
As much as i'd like this in 2.7, i'm leaving it open to consideration if its even going to make it into 2.8, I'll work around it in my plugin for now..