WordPress.org

Make WordPress Core

Ticket #11638: 11638.2.diff

File 11638.2.diff, 1.0 KB (added by nacin, 4 years ago)

We also need to bump the local $wp_version to 2.9.1. See also #11639.

  • update-core.php

     
    223223        $mysql_version  = $wpdb->db_version(); 
    224224        $required_php_version = '4.3'; 
    225225        $required_mysql_version = '4.1.2'; 
    226         $wp_version = '2.9'; 
     226        $wp_version = '2.9.1'; 
    227227        $php_compat     = version_compare( $php_version, $required_php_version, '>=' ); 
    228228        $mysql_compat   = version_compare( $mysql_version, $required_mysql_version, '>=' ) || file_exists( WP_CONTENT_DIR . '/db.php' ); 
    229229 
     230        if ( !$mysql_compat || !$php_compat ) 
     231                $wp_filesystem->delete($from, true); 
     232 
    230233        if ( !$mysql_compat && !$php_compat ) 
    231234                return new WP_Error( 'php_mysql_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ) ); 
    232235        elseif ( !$php_compat )