WordPress.org

Make WordPress Core

Ticket #13310: 13310-420.patch

File 13310-420.patch, 1.7 KB (added by khromov, 6 years ago)
  • wp-admin/includes/schema.php

     
    123123) $charset_collate;
    124124CREATE TABLE $wpdb->options (
    125125  option_id bigint(20) unsigned NOT NULL auto_increment,
    126   option_name varchar(64) NOT NULL default '',
     126  option_name varchar(255) NOT NULL default '',
    127127  option_value longtext NOT NULL,
    128128  autoload varchar(20) NOT NULL default 'yes',
    129129  PRIMARY KEY  (option_id),
  • wp-admin/includes/upgrade.php

     
    442442        if ( $wp_current_db_version < 29630 )
    443443                upgrade_400();
    444444
     445        if ( $wp_current_db_version < 30975 )
     446                upgrade_420();
     447
    445448        maybe_disable_link_manager();
    446449
    447450        maybe_disable_automattic_widgets();
     
    13291332}
    13301333
    13311334/**
     1335 * Execute changes made in WordPress 4.2.0.
     1336 * ALTER TABLE <table_name> MODIFY <col_name> VARCHAR(65536)
     1337 *
     1338 * @since 4.2.0
     1339 */
     1340function upgrade_420() {
     1341        global $wpdb;
     1342
     1343        $wpdb->hide_errors();
     1344        $wpdb->query("ALTER TABLE {$wpdb->options} MODIFY option_name VARCHAR(255)");
     1345        $wpdb->show_errors();
     1346        return true;
     1347}
     1348
     1349/**
    13321350 * Execute network level changes
    13331351 *
    13341352 * @since 3.0.0
  • wp-includes/version.php

     
    1111 *
    1212 * @global int $wp_db_version
    1313 */
    14 $wp_db_version = 30133;
     14$wp_db_version = 30975;
    1515
    1616/**
    1717 * Holds the TinyMCE version