WordPress.org

Make WordPress Core

Ticket #15042: require_plugin.php_earlier.diff

File require_plugin.php_earlier.diff, 681 bytes (added by andy, 4 years ago)
  • wp-settings.php

     
    6666require( ABSPATH . WPINC . '/compat.php' ); 
    6767require( ABSPATH . WPINC . '/functions.php' ); 
    6868require( ABSPATH . WPINC . '/classes.php' ); 
     69require( ABSPATH . WPINC . '/plugin.php' ); 
    6970 
    7071// Include the wpdb class and, if present, a db.php database drop-in. 
    7172require_wp_db(); 
     
    7778wp_start_object_cache(); 
    7879 
    7980// Load early WordPress files. 
    80 require( ABSPATH . WPINC . '/plugin.php' ); 
    8181require( ABSPATH . WPINC . '/default-filters.php' ); 
    8282require( ABSPATH . WPINC . '/pomo/mo.php' ); 
    8383