WordPress.org

Make WordPress Core

Ticket #23685: globalize-version-vars-in-wp-settings.diff

File globalize-version-vars-in-wp-settings.diff, 808 bytes (added by nbachiyski, 5 years ago)
  • wp-settings.php

     
    2020// Include files required for initialization.
    2121require( ABSPATH . WPINC . '/load.php' );
    2222require( ABSPATH . WPINC . '/default-constants.php' );
     23
     24/*
     25 * We can't globalzie them directly in version.php, because when updating
     26 * we're including version.php from another install and we wouldn't want
     27 * this to replace the current version globals
     28 */
     29global $wp_version, $wp_db_version, $tinymce_version, $required_php_version, $required_mysql_version;
    2330require( ABSPATH . WPINC . '/version.php' );
    2431
    2532// Set initial default constants including WP_MEMORY_LIMIT, WP_MAX_MEMORY_LIMIT, WP_DEBUG, WP_CONTENT_DIR and WP_CACHE.