WordPress.org

Make WordPress Core

Ticket #43828: 43828.3.diff

File 43828.3.diff, 1.7 KB (added by kamataryo, 5 months ago)

Fixed the broken patch 43828.2.dff

  • .eslintignore

     
     1# Files and folders related to build/test tools
     2/build
     3/node_modules
     4/tests
     5/vendor
     6/tools
     7/Gruntfile.js
     8/webpack.config.js
     9
     10# Excluded files and folders based on `jsdoc.conf.json` exclusions
     11/src/js/_enqueue/vendor
  • .eslintrc.js

     
     1module.exports = {
     2        rules: {
     3                'require-jsdoc': 'off',
     4                'valid-jsdoc': [ 'error', {
     5                        prefer: {
     6                                arg: 'param',
     7                                argument: 'param',
     8                                extends: 'augments',
     9                                returns: 'return',
     10                        },
     11                        preferType: {
     12                                array: 'Array',
     13                                bool: 'boolean',
     14                                Boolean: 'boolean',
     15                                float: 'number',
     16                                Float: 'number',
     17                                int: 'number',
     18                                integer: 'number',
     19                                Integer: 'number',
     20                                Number: 'number',
     21                                object: 'Object',
     22                                String: 'string',
     23                                Void: 'void',
     24                        },
     25                        requireParamDescription: false,
     26                        requireReturn: false,
     27                } ],
     28        },
     29};
  • package.json

     
    1515        "devDependencies": {
    1616                "@wordpress/custom-templated-path-webpack-plugin": "1.2.0",
    1717                "@wordpress/library-export-default-webpack-plugin": "1.1.0",
     18                "@wordpress/scripts": "3.3.0",
    1819                "autoprefixer": "9.4.7",
    1920                "check-node-version": "3.2.0",
    2021                "copy-webpack-plugin": "^4.6.0",
     
    117118                "dev": "grunt build --dev",
    118119                "test": "grunt test",
    119120                "watch": "grunt watch",
    120                 "grunt": "grunt"
     121                "grunt": "grunt",
     122                "lint:js": "wp-scripts lint-js"
    121123        }
    122124}