WordPress.org

Make WordPress Core

Ticket #47699: 47699-WP-5.2.x-site-health-json-required.patch

File 47699-WP-5.2.x-site-health-json-required.patch, 886 bytes (added by jrf, 14 months ago)

WP 5.2.x: make JSON a required extension for Site_Health, patch created against the WP 5.2 branch

  • src/wp-admin/includes/class-wp-site-health.php

    From 921a8320843e1c9e0c9fac6953bc9b4e2210085f Mon Sep 17 00:00:00 2001
    From: jrfnl <jrfnl@users.noreply.github.com>
    Date: Fri, 19 Jul 2019 11:32:42 +0200
    Subject: [PATCH] WP 5.2.x: make JSON a required extension for Site_Health
    
    ---
     src/wp-admin/includes/class-wp-site-health.php | 4 ++++
     1 file changed, 4 insertions(+)
    
    diff --git a/src/wp-admin/includes/class-wp-site-health.php b/src/wp-admin/includes/class-wp-site-health.php
    index 12e127353b..746cbdca13 100644
    a b class WP_Site_Health { 
    777777                                'function' => 'finfo_file',
    778778                                'required' => false,
    779779                        ),
     780                        'json'      => array(
     781                                'function' => 'json_last_error',
     782                                'required' => true,
     783                        ),
    780784                        'mod_xml'   => array(
    781785                                'extension' => 'libxml',
    782786                                'required'  => false,