WordPress.org

Make WordPress Core

Ticket #48245: 48245.diff

File 48245.diff, 1.6 KB (added by stuffradio, 16 months ago)
  • wp-admin/includes/plugin.php

    diff --git a/wp-admin/includes/plugin.php b/wp-admin/includes/plugin.php
    index e3af2ce240..f630dd345a 100644
    a b function validate_plugin_requirements( $plugin ) { 
    11521152                return new WP_Error(
    11531153                        'plugin_wp_php_incompatible',
    11541154                        sprintf(
    1155                                 /* translators: %s: Plugin name. */
    1156                                 _x( 'Current WordPress and PHP versions do not meet minimum requirements for %s.', 'plugin' ),
    1157                                 $plugin_headers['Name']
     1155                                /* translators: WordPress version, PHP version, Plugin name. */
     1156                                _x( 'Current WordPress and PHP versions do not meet minimum requirements of %s and %s for %s.', 'plugin' ),
     1157                                $requirements['requires'], $requirements['requires_php'], $plugin_headers['Name']
    11581158                        )
    11591159                );
    11601160        } elseif ( ! $compatible_php ) {
    11611161                return new WP_Error(
    11621162                        'plugin_php_incompatible',
    11631163                        sprintf(
    1164                                 /* translators: %s: Plugin name. */
    1165                                 _x( 'Current PHP version does not meet minimum requirements for %s.', 'plugin' ),
    1166                                 $plugin_headers['Name']
     1164                                /* translators: PHP version, Plugin name. */
     1165                                _x( 'Current PHP version does not meet minimum requirements of %s for %s.', 'plugin' ),
     1166                                $requirements['requires_php'], $plugin_headers['Name']
    11671167                        )
    11681168                );
    11691169        } elseif ( ! $compatible_wp ) {
    11701170                return new WP_Error(
    11711171                        'plugin_wp_incompatible',
    11721172                        sprintf(
    1173                                 /* translators: %s: Plugin name. */
     1173                                /* translators: WordPress version, Plugin name. */
    11741174                                _x( 'Current WordPress version does not meet minimum requirements for %s.', 'plugin' ),
    1175                                 $plugin_headers['Name']
     1175                                $requirements['requires'], $plugin_headers['Name']
    11761176                        )
    11771177                );
    11781178        }