WordPress.org

Make WordPress Core

Changeset 10421


Ignore:
Timestamp:
01/23/2009 06:05:48 PM (9 years ago)
Author:
westi
Message:

Sort out the error_reporting for PHP 5.3. See #8701 for 2.7.x.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/2.7/wp-settings.php

    r10419 r10421  
    202202    error_reporting(E_ALL);
    203203} else {
    204     if ( defined( 'E_DEPRECATED' ) )
    205         error_reporting(E_ALL ^ E_STRICT ^ E_DEPRECATED ^ E_NOTICE ^ E_USER_NOTICE);
    206     else if ( defined( 'E_STRICT' ) )
     204    if ( defined( 'E_DEPRECATED' ) ) // Introduced in PHP 5.3
     205        error_reporting( (E_ALL ^ E_DEPRECATED ^ E_NOTICE ^ E_USER_NOTICE) & E_STRICT);
     206    else if ( defined( 'E_STRICT' ) ) // Introduced in PHP 5.0 not part of E_ALL
    207207        error_reporting( ( E_ALL ^ E_NOTICE ^ E_USER_NOTICE ) & E_STRICT);
    208208    else
Note: See TracChangeset for help on using the changeset viewer.