WordPress.org

Make WordPress Core


Ignore:
Timestamp:
03/10/2009 06:31:55 PM (12 years ago)
Author:
ryan
Message:

Cleanup plugin compatibility messages. Props DD32. fixes #8868

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-admin/includes/plugin-install.php

    r10606 r10759  
    156156                                'id' => sanitize_title_with_dashes($tag['name']),
    157157                                'count' => $tag['count'] );
     158    echo '<p>';
    158159    echo wp_generate_tag_cloud($tags, array( 'single_text' => __('%d plugin'), 'multiple_text' => __('%d plugins') ) );
     160    echo '</p><br class="clear" />';
    159161}
    160162
     
    506508    <div id="section-holder" class="wrap">
    507509    <?php
    508         if ( version_compare($GLOBALS['wp_version'], $api->tested, '>') )
     510        if ( !empty($api->tested) && version_compare( substr($GLOBALS['wp_version'], 0, strlen($api->tested)), $api->tested, '>') )
    509511            echo '<div class="updated"><p>' . __('<strong>Warning:</strong> This plugin has <strong>not been tested</strong> with your current version of WordPress.') . '</p></div>';
    510         else if ( version_compare($GLOBALS['wp_version'], $api->requires, '<') )
    511             echo '<div class="updated"><p>' . __('<strong>Warning:</strong> This plugin has not been marked as <strong>compatible</strong> with your version of WordPress.') . '</p></div>';
     512
     513        else if ( !empty($api->requires) && version_compare( substr($GLOBALS['wp_version'], 0, strlen($api->requires)), $api->requires, '<') )
     514            echo '<div class="updated"><p>' . __('<strong>Warning:</strong> This plugin has <strong>not been marked as compatible</strong> with your version of WordPress.') . '</p></div>';
     515
    512516        foreach ( (array)$api->sections as $section_name => $content ) {
    513517            $title = $section_name;
Note: See TracChangeset for help on using the changeset viewer.