WordPress.org

Make WordPress Core


Ignore:
Timestamp:
12/23/2009 06:35:12 PM (12 years ago)
Author:
ryan
Message:

Check required php and mysql versions in the update response and notify if the server environment does not meet those requirements. fixes #11562

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-includes/update.php

    r12348 r12523  
    4545        $mysql_version = 'N/A';
    4646    $local_package = isset( $wp_local_package )? $wp_local_package : '';
    47     $url = "http://api.wordpress.org/core/version-check/1.3/?version=$wp_version&php=$php_version&locale=$locale&mysql=$mysql_version&local_package=$local_package";
     47    $url = "http://api.wordpress.org/core/version-check/1.4/?version=$wp_version&php=$php_version&locale=$locale&mysql=$mysql_version&local_package=$local_package";
    4848
    4949    $options = array(
     
    7575        if ( isset( $returns[4] ) )
    7676            $new_option->locale = esc_attr( $returns[4] );
     77        if ( isset( $returns[5] ) )
     78            $new_option->php_version = esc_attr( $returns[5] );
     79        if ( isset( $returns[6] ) )
     80            $new_option->mysql_version = esc_attr( $returns[6] );
    7781        $new_options[] = $new_option;
    7882    }
Note: See TracChangeset for help on using the changeset viewer.