WordPress.org

Make WordPress Core

Changeset 13027


Ignore:
Timestamp:
02/08/10 18:24:01 (6 years ago)
Author:
ryan
Message:

Use post_password_required(). see #9015

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-content/themes/twentyten/comments.php

    r13024 r13027  
    55    if ( 'comments.php' == basename($_SERVER['SCRIPT_FILENAME']) ) 
    66        die ( 'Please do not load this page directly. Thanks!' ); 
    7     if ( ! empty($post->post_password) ) : 
    8         if ( $_COOKIE['wp-postpass_' . COOKIEHASH] != $post->post_password ) : 
     7    if ( post_password_required() ) : 
    98?> 
    109                <div class="nopassword"><?php _e('This post is password protected. Enter the password to view any comments.', 'twentyten') ?></div> 
     
    1312        return; 
    1413    endif; 
    15 endif; 
    1614?> 
    1715 
Note: See TracChangeset for help on using the changeset viewer.