Make WordPress Core


Ignore:
Timestamp:
12/02/2010 09:45:47 PM (13 years ago)
Author:
markjaquith
Message:

Standardize around "Update" instead of "Upgrade." props RanYanivHartstein. props latz. fixes #14107

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-admin/upgrade.php

    r16660 r16696  
    4747<head>
    4848    <meta http-equiv="Content-Type" content="<?php bloginfo( 'html_type' ); ?>; charset=<?php echo get_option( 'blog_charset' ); ?>" />
    49     <title><?php _e( 'WordPress &rsaquo; Upgrade' ); ?></title>
     49    <title><?php _e( 'WordPress &rsaquo; Update' ); ?></title>
    5050    <?php
    5151    wp_admin_css( 'install', true );
     
    5858<?php if ( get_option( 'db_version' ) == $wp_db_version || !is_blog_installed() ) : ?>
    5959
    60 <h2><?php _e( 'No Upgrade Required' ); ?></h2>
     60<h2><?php _e( 'No Update Required' ); ?></h2>
    6161<p><?php _e( 'Your WordPress database is already up-to-date!' ); ?></p>
    6262<p class="step"><a class="button" href="<?php echo get_option( 'home' ); ?>/"><?php _e( 'Continue' ); ?></a></p>
     
    6464<?php elseif ( !$php_compat || !$mysql_compat ) :
    6565    if ( !$mysql_compat && !$php_compat )
    66         printf( __('You cannot upgrade because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version );
     66        printf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version );
    6767    elseif ( !$php_compat )
    68         printf( __('You cannot upgrade because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version );
     68        printf( __('You cannot udate because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version );
    6969    elseif ( !$mysql_compat )
    70         printf( __('You cannot upgrade because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires MySQL version %2$s or higher. You are running version %3$s.'), $wp_version, $required_mysql_version, $mysql_version );
     70        printf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires MySQL version %2$s or higher. You are running version %3$s.'), $wp_version, $required_mysql_version, $mysql_version );
    7171?>
    7272<?php else :
     
    7777        $goback = urlencode( $goback );
    7878?>
    79 <h2><?php _e( 'Database Upgrade Required' ); ?></h2>
    80 <p><?php _e( 'WordPress has been updated! Before we send you on your way, we have to upgrade your database to the newest version.' ); ?></p>
    81 <p><?php _e( 'The upgrade process may take a little while, so please be patient.' ); ?></p>
    82 <p class="step"><a class="button" href="upgrade.php?step=1&amp;backto=<?php echo $goback; ?>"><?php _e( 'Upgrade WordPress Database' ); ?></a></p>
     79<h2><?php _e( 'Database Update Required' ); ?></h2>
     80<p><?php _e( 'WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.' ); ?></p>
     81<p><?php _e( 'The update process may take a little while, so please be patient.' ); ?></p>
     82<p class="step"><a class="button" href="upgrade.php?step=1&amp;backto=<?php echo $goback; ?>"><?php _e( 'Update WordPress Database' ); ?></a></p>
    8383<?php
    8484        break;
     
    9090            $backto = wp_validate_redirect($backto, __get_option( 'home' ) . '/');
    9191?>
    92 <h2><?php _e( 'Upgrade Complete' ); ?></h2>
    93     <p><?php _e( 'Your WordPress database has been successfully upgraded!' ); ?></p>
     92<h2><?php _e( 'Update Complete' ); ?></h2>
     93    <p><?php _e( 'Your WordPress database has been successfully updated!' ); ?></p>
    9494    <p class="step"><a class="button" href="<?php echo $backto; ?>"><?php _e( 'Continue' ); ?></a></p>
    9595
Note: See TracChangeset for help on using the changeset viewer.