Make WordPress Core

Changeset 2171


Ignore:
Timestamp:
01/31/2005 10:28:53 AM (19 years ago)
Author:
saxmatt
Message:

If we're already in wp-admin don't recursive link

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-settings.php

    r2161 r2171  
    6262
    6363$wpdb->hide_errors();
    64 if ( !update_user_cache() && !strstr($_SERVER['PHP_SELF'], 'install.php') )
    65     die("It doesn't look like you've installed WP yet. Try running <a href='wp-admin/install.php'>install.php</a>.");
     64if ( !update_user_cache() && !strstr($_SERVER['PHP_SELF'], 'install.php') ) {
     65    if ( strstr($_SERVER['PHP_SELF'], 'wp-admin') )
     66        $link = 'install.php';
     67    else
     68        $link = 'wp-admin/install.php';
     69    die("It doesn't look like you've installed WP yet. Try running <a href='$link'>install.php</a>.");
     70}
    6671$wpdb->show_errors();
    6772
Note: See TracChangeset for help on using the changeset viewer.