WordPress.org

Make WordPress Core


Ignore:
Timestamp:
12/17/2012 05:29:40 PM (9 years ago)
Author:
nacin
Message:

Update to jQuery 1.9 Beta 1 in trunk (3.6-alpha).

Temporarily includes jQuery in original, unminified form, for ease of testing and bug reporting.

jQuery 1.9 introduces a "migrate" script for deprecated and removed behavior. Warnings are issued for methods we should not be using, and should be fixed in core. These warnings are sent to the JavaScript console and are collected in jQuery.migrateWarnings.

See http://blog.jquery.com/2012/12/17/jquery-1-9-beta-1-released/ for more.

props ocean90, see #22975.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-includes/script-loader.php

    r23074 r23180  
    125125    $scripts->add( 'cropper', '/wp-includes/js/crop/cropper.js', array('scriptaculous-dragdrop') );
    126126
    127     $scripts->add( 'jquery', '/wp-includes/js/jquery/jquery.js', array(), '1.8.3' );
     127    // jQuery
     128    $scripts->add( 'jquery-migrate', '/wp-includes/js/jquery/jquery.js', array(), '1.9.0b1' );
     129    $scripts->add( 'jquery', '/wp-includes/js/jquery/jquery-migrate.js', array( 'jquery-migrate' ), '1.0.0b1' );
    128130
    129131    // full jQuery UI
Note: See TracChangeset for help on using the changeset viewer.