WordPress.org

Make WordPress Core

Changeset 23297


Ignore:
Timestamp:
01/11/13 10:16:45 (15 months ago)
Author:
dd32
Message:

Core Update: Fix a issue which caused automatic upgrades from 2.7 to 3.5+ to fail. Pre-2.7 WP_Filesystem::wp_content_dir() returned unslashed paths. Introduced in [22227]. See #23177

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-admin/includes/update-core.php

    r23253 r23297  
    645645 
    646646    // Import $wp_version, $required_php_version, and $required_mysql_version from the new version 
    647     $versions_file = $wp_filesystem->wp_content_dir() . 'upgrade/version-current.php'; 
     647    // $wp_filesystem->wp_content_dir() returned unslashed pre-2.8 
     648    $versions_file = trailingslashit( $wp_filesystem->wp_content_dir() ) . 'upgrade/version-current.php'; 
    648649    if ( ! $wp_filesystem->copy( $from . $distro . 'wp-includes/version.php', $versions_file ) ) { 
    649650         $wp_filesystem->delete( $from, true ); 
Note: See TracChangeset for help on using the changeset viewer.