Make WordPress Core


Ignore:
Timestamp:
04/22/2013 07:37:26 PM (11 years ago)
Author:
nacin
Message:

Customize requires edit_theme_options. If you only have switch_themes (rare, but a case that core supports), you should not have access. fixes #21413.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-admin/menu.php

    r24048 r24049  
    141141$menu[60] = array( __('Appearance'), $appearance_cap, 'themes.php', '', 'menu-top menu-icon-appearance', 'menu-appearance', 'div' );
    142142    $submenu['themes.php'][5] = array( __( 'Themes' ), $appearance_cap, 'themes.php' );
    143     $submenu['themes.php'][6] = array( __( 'Customize' ), $appearance_cap, 'customize.php', 'hide-if-no-customize' );
     143    $submenu['themes.php'][6] = array( __( 'Customize' ), 'edit_theme_options', 'customize.php', 'hide-if-no-customize' );
    144144    if ( current_theme_supports( 'menus' ) || current_theme_supports( 'widgets' ) )
    145145        $submenu['themes.php'][10] = array(__( 'Menus' ), 'edit_theme_options', 'nav-menus.php');
Note: See TracChangeset for help on using the changeset viewer.