WordPress.org

Make WordPress Core

Changeset 25674


Ignore:
Timestamp:
10/02/2013 09:49:34 PM (5 years ago)
Author:
nacin
Message:

Don't use a double negative.

props TobiasBg.
fixes #18201.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/includes/class-wp-upgrader.php

    r25658 r25674  
    12551255        get_core_checksums( array( $wp_version, $current->version ) );
    12561256
    1257         $no_partial = false;
     1257        $partial = true;
    12581258        if ( $parsed_args['do_rollback'] )
    1259             $no_partial = true;
     1259            $partial = false;
    12601260        elseif ( $parsed_args['pre_check_md5'] && ! $this->check_files() )
    1261             $no_partial = true;
     1261            $partial = false;
    12621262
    12631263        // If partial update is returned from the API, use that, unless we're doing a reinstall.
     
    12671267        if ( $parsed_args['do_rollback'] && $current->packages->rollback )
    12681268            $to_download = 'rollback';
    1269         elseif ( $current->packages->partial && 'reinstall' != $current->response && $wp_version == $current->partial_version && ! $no_partial )
     1269        elseif ( $current->packages->partial && 'reinstall' != $current->response && $wp_version == $current->partial_version && $partial )
    12701270            $to_download = 'partial';
    12711271        elseif ( $current->packages->new_bundled && version_compare( $wp_version, $current->new_bundled, '<' )
Note: See TracChangeset for help on using the changeset viewer.