WordPress.org

Make WordPress Core

Changeset 25798


Ignore:
Timestamp:
10/15/13 20:34:02 (4 years ago)
Author:
nacin
Message:

Avoid our pre-flight writable checks if get_core_checksums() doesn't exist yet.

Thus, it will not work for 3.6 => 3.7, only 3.7+.

see #22704.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/includes/update-core.php

    r25797 r25798  
    711711 
    712712    // If we're using the direct method, we can predict write failures that are due to permissions. 
    713     if ( $wp_filesystem->method === 'direct' ) { 
     713    if ( $check_is_writable && 'direct' === $wp_filesystem->method ) { 
    714714        $files_writable = array_filter( $check_is_writable, array( $wp_filesystem, 'is_writable' ) ); 
    715715        if ( $files_writable !== $check_is_writable ) { 
Note: See TracChangeset for help on using the changeset viewer.