Make WordPress Core

Changeset 26692


Ignore:
Timestamp:
12/05/2013 09:29:37 PM (8 years ago)
Author:
nacin
Message:

Deactivate MP6 on update to 3.8.

If left on, it introduces a lot of weird issues not easily diagnosed. MP6 will be updated before release to prevent itself from functioning 3.8+, but this will cut down on support requests by people who update core but not MP6, which was a fairly popular plugin.

fixes #26334.

Location:
trunk/src
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/includes/upgrade.php

    r26566 r26692  
    409409        upgrade_372();
    410410
     411    if ( $wp_current_db_version < 26691 )
     412        upgrade_380();
     413
    411414    maybe_disable_link_manager();
    412415
     
    12381241}
    12391242
     1243/**
     1244 * Execute changes made in WordPress 3.8.0.
     1245 *
     1246 * @since 3.8.0
     1247 */
     1248function upgrade_380() {
     1249    global $wp_current_db_version;
     1250    if ( $wp_current_db_version < 26691 ) {
     1251        deactivate_plugins( array( 'mp6/mp6.php' ), true );
     1252    }
     1253}
    12401254/**
    12411255 * Execute network level changes
  • trunk/src/wp-includes/version.php

    r26644 r26692  
    1212 * @global int $wp_db_version
    1313 */
    14 $wp_db_version = 26644;
     14$wp_db_version = 26691;
    1515
    1616/**
Note: See TracChangeset for help on using the changeset viewer.