WordPress.org

Make WordPress Core

Changeset 28203


Ignore:
Timestamp:
04/24/2014 10:05:42 PM (6 years ago)
Author:
nacin
Message:

Run WP_Editors::enqueue_scripts() on admin_print_footer_scripts, instead of admin_footer.

Fixes incompatibility with the customizer.

Merges [28187] to the 3.9 branch.

props feedmeastraycat.
fixes #27853.

Location:
branches/3.9
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • branches/3.9

  • branches/3.9/src/wp-includes/class-wp-editor.php

    r28116 r28203  
    242242        if ( empty(self::$first_init) ) {
    243243            if ( is_admin() ) {
    244                 add_action( 'admin_print_footer_scripts', array( __CLASS__, 'editor_js'), 50 );
    245                 add_action( 'admin_footer', array( __CLASS__, 'enqueue_scripts'), 1 );
     244                add_action( 'admin_print_footer_scripts', array( __CLASS__, 'editor_js' ), 50 );
     245                add_action( 'admin_print_footer_scripts', array( __CLASS__, 'enqueue_scripts' ), 1 );
    246246            } else {
    247                 add_action( 'wp_print_footer_scripts', array( __CLASS__, 'editor_js'), 50 );
    248                 add_action( 'wp_footer', array( __CLASS__, 'enqueue_scripts'), 1 );
     247                add_action( 'wp_print_footer_scripts', array( __CLASS__, 'editor_js' ), 50 );
     248                add_action( 'wp_print_footer_scripts', array( __CLASS__, 'enqueue_scripts' ), 1 );
    249249            }
    250250        }
Note: See TracChangeset for help on using the changeset viewer.