WordPress.org

Make WordPress Core


Ignore:
Timestamp:
05/19/2014 05:03:44 AM (5 years ago)
Author:
wonderboymusic
Message:

Fix some hackificator odds and ends in wp-admin:

  • wp-activate.php and wp-admin/themes.php don't need the closing PHP tag
  • Switch single quotes for HTML attribute values to double in a few places
  • Convert include_once file.php syntax to include_once( 'file.php' )
  • Add access modifiers to methods/members in: _WP_List_Table_Compat, Walker_Nav_Menu_Edit, Walker_Nav_Menu_Checklist, WP_Screen, Walker_Category_Checklist
  • edit_user() doesn't need to import the $wpdb global
  • wp_list_widgets() doesn't need to import the $sidebars_widgets global
  • switch/endswitch syntax is not supported in Hack
  • A <ul> in wp-admin/users.php is unclosed

See #27881.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/options.php

    r28083 r28500  
    205205  <?php wp_nonce_field('options-options') ?>
    206206  <input type="hidden" name="action" value="update" />
    207   <input type='hidden' name='option_page' value='options' />
     207  <input type="hidden" name="option_page" value="options" />
    208208  <table class="form-table">
    209209<?php
Note: See TracChangeset for help on using the changeset viewer.