WordPress.org

Make WordPress Core

Changeset 29621


Ignore:
Timestamp:
08/26/2014 09:19:17 AM (5 years ago)
Author:
ocean90
Message:

Language Pack Upgrader: Remove any pre-existing package checks and then set the new one for translations.

fixes #29230.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/includes/class-wp-upgrader.php

    r29479 r29621  
    12571257            $this->skin->feedback( 'starting_upgrade' );
    12581258
    1259         add_filter( 'upgrader_source_selection', array( &$this, 'check_package' ), 10, 3 );
     1259        // Remove any existing package checks and then set the new one for translations, #WP29230.
     1260        remove_all_filters( 'upgrader_source_selection' );
     1261        add_filter( 'upgrader_source_selection', array( $this, 'check_package' ), 10, 2 );
    12601262
    12611263        $this->skin->header();
     
    13211323
    13221324        // Clean up our hooks, in case something else does an upgrade on this connection.
    1323         remove_filter( 'upgrader_source_selection', array( &$this, 'check_package' ), 10, 2 );
     1325        remove_filter( 'upgrader_source_selection', array( $this, 'check_package' ) );
    13241326
    13251327        if ( $parsed_args['clear_update_cache'] ) {
Note: See TracChangeset for help on using the changeset viewer.