WordPress.org

Make WordPress Core

Changeset 35332


Ignore:
Timestamp:
10/21/2015 04:47:21 PM (6 years ago)
Author:
jorbin
Message:

Replace Autoprefixer Core with Autoprefixer

Autoprefixer Core 5.2.1 -> Autoprefixer 6.0.3 https://github.com/postcss/autoprefixer/releases/tag/6.0.0
Package autoprefixer-core is deprecated in favour of autoprefixer as part of the 6.0.0 release:
Packages autoprefixer and autoprefixer-core were merged in 6.0 release.
Autoprefixer 6.0.0 requires PostCSS 5.0.10 or greater
PostCSS 0.5.4 -> 0.6.0 https://github.com/nDmitry/grunt-postcss/compare/v0.5.4...v0.6.0

You will need to update your dev dependencies after this change.

Props netweb
See #34177

Location:
trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/Gruntfile.js

    r35235 r35332  
    44        SOURCE_DIR = 'src/',
    55        BUILD_DIR = 'build/',
    6         autoprefixer = require('autoprefixer-core'),
     6        autoprefixer = require('autoprefixer'),
    77        mediaConfig = {},
    88        mediaBuilds = ['audiovideo', 'grid', 'models', 'views'];
  • trunk/package.json

    r34888 r35332  
    1010  "license": "GPL-2.0+",
    1111  "devDependencies": {
    12     "autoprefixer-core": "~5.2.1",
     12    "autoprefixer": "~6.0.3",
    1313    "grunt": "~0.4.5",
    1414    "grunt-browserify": "~4.0.0",
     
    2727    "grunt-legacy-util": "^0.2.0",
    2828    "grunt-patch-wordpress": "~0.3.0",
    29     "grunt-postcss": "~0.5.4",
     29    "grunt-postcss": "~0.6.0",
    3030    "grunt-rtlcss": "~1.6.0",
    3131    "grunt-sass": "~1.0.0",
Note: See TracChangeset for help on using the changeset viewer.