WordPress.org

Make WordPress Core


Ignore:
Timestamp:
10/25/2016 03:14:31 AM (3 years ago)
Author:
dd32
Message:

Drop the requirement for the entry points to WordPress to be parsable by PHP4.

Previously we ensured that the entry points to WordPress were parsable by PHP4 in order to display a friendly not-supported-php error message.
However, for the last two years the main entry points have not actually parsed, and we've only added extra parse errors since it last worked in 3.9, so it's time we just remove this 'feature'.
The PHP version checks are still there for PHP 5.0/5.1, and so it's inplace when we eventually drop PHP 5.2 support.

See #29489.

File:
1 edited

Legend:

Unmodified
Added
Removed
Note: See TracChangeset for help on using the changeset viewer.