WordPress.org

Make WordPress Core


Ignore:
Timestamp:
11/21/2016 01:21:01 AM (3 years ago)
Author:
johnbillion
Message:

I18n: Begin introducing translator comments for strings which include placeholders but no accompanying translator comment.

Adds context to one string used in two different contexts for the new user and new site signup email notification.

More to come.

See #38882

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/install.php

    r38672 r39323  
    233233$mysql_compat   = version_compare( $mysql_version, $required_mysql_version, '>=' ) || file_exists( WP_CONTENT_DIR . '/db.php' );
    234234
    235 if ( !$mysql_compat && !$php_compat )
     235if ( !$mysql_compat && !$php_compat ) {
     236    /* translators: 1: WordPress version number, 2: Minimum required PHP version number, 3: Minimum required MySQL version number, 4: Current PHP version number, 5: Current MySQL version number */
    236237    $compat = sprintf( __( 'You cannot install because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.' ), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version );
    237 elseif ( !$php_compat )
     238} elseif ( !$php_compat ) {
     239    /* translators: 1: WordPress version number, 2: Minimum required PHP version number, 3: Current PHP version number */
    238240    $compat = sprintf( __( 'You cannot install because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.' ), $wp_version, $required_php_version, $php_version );
    239 elseif ( !$mysql_compat )
     241} elseif ( !$mysql_compat ) {
     242    /* translators: 1: WordPress version number, 2: Minimum required MySQL version number, 3: Current MySQL version number */
    240243    $compat = sprintf( __( 'You cannot install because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires MySQL version %2$s or higher. You are running version %3$s.' ), $wp_version, $required_mysql_version, $mysql_version );
     244}
    241245
    242246if ( !$mysql_compat || !$php_compat ) {
Note: See TracChangeset for help on using the changeset viewer.