Make WordPress Core


Ignore:
Timestamp:
11/21/2016 01:21:01 AM (7 years ago)
Author:
johnbillion
Message:

I18n: Begin introducing translator comments for strings which include placeholders but no accompanying translator comment.

Adds context to one string used in two different contexts for the new user and new site signup email notification.

More to come.

See #38882

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-includes/wp-db.php

    r39275 r39323  
    13651365        wp_load_translations_early();
    13661366
    1367         if ( $caller = $this->get_caller() )
     1367        if ( $caller = $this->get_caller() ) {
     1368            /* translators: 1: Database error message, 2: SQL query, 3: Name of the calling function */
    13681369            $error_str = sprintf( __( 'WordPress database error %1$s for query %2$s made by %3$s' ), $str, $this->last_query, $caller );
    1369         else
     1370        } else {
     1371            /* translators: 1: Database error message, 2: SQL query */
    13701372            $error_str = sprintf( __( 'WordPress database error %1$s for query %2$s' ), $str, $this->last_query );
     1373        }
    13711374
    13721375        error_log( $error_str );
     
    32143217        global $wp_version, $required_mysql_version;
    32153218        // Make sure the server has the required MySQL version
    3216         if ( version_compare($this->db_version(), $required_mysql_version, '<') )
     3219        if ( version_compare($this->db_version(), $required_mysql_version, '<') ) {
     3220            /* translators: 1: WordPress version number, 2: Minimum required MySQL version number */
    32173221            return new WP_Error('database_version', sprintf( __( '<strong>ERROR</strong>: WordPress %1$s requires MySQL %2$s or higher' ), $wp_version, $required_mysql_version ));
     3222        }
    32183223    }
    32193224
Note: See TracChangeset for help on using the changeset viewer.