WordPress.org

Make WordPress Core

Changeset 41297


Ignore:
Timestamp:
08/22/2017 05:14:15 PM (2 years ago)
Author:
johnbillion
Message:

Build/Test tools: Use the latest in the 4.x and 5.x branches of PHPUnit when running tests on Travis for the 4.6 branch.

See #41472

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/4.6/.travis.yml

    r41075 r41297  
    5555    case "$TRAVIS_PHP_VERSION" in
    5656      7.1|7.0|nightly)
    57         echo "Using PHPUnit 5.7"
    58         composer global require "phpunit/phpunit=5.7.*"
     57        echo "Using PHPUnit 5.x"
     58        composer global require "phpunit/phpunit:^5"
    5959        ;;
    6060      5.6|5.5|5.4|5.3)
    61         echo "Using PHPUnit 4.8"
    62         composer global require "phpunit/phpunit=4.8.*"
     61        echo "Using PHPUnit 4.x"
     62        composer global require "phpunit/phpunit:^4"
    6363        ;;
    6464      5.2)
Note: See TracChangeset for help on using the changeset viewer.