WordPress.org

Make WordPress Core

Changeset 41301


Ignore:
Timestamp:
08/22/2017 05:26:22 PM (2 years ago)
Author:
johnbillion
Message:

Build/Test tools: Use the latest in the 4.x and 5.x branches of PHPUnit when running tests on Travis for the 4.2 branch.

See #41472

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/4.2/.travis.yml

    r41080 r41301  
    4646    case "$TRAVIS_PHP_VERSION" in
    4747      7.1|7.0|nightly)
    48         echo "Using PHPUnit 5.7"
    49         composer global require "phpunit/phpunit=5.7.*"
     48        echo "Using PHPUnit 5.x"
     49        composer global require "phpunit/phpunit:^5"
    5050        ;;
    5151      5.6|5.5|5.4|5.3)
    52         echo "Using PHPUnit 4.8"
    53         composer global require "phpunit/phpunit=4.8.*"
     52        echo "Using PHPUnit 4.x"
     53        composer global require "phpunit/phpunit:^4"
    5454        ;;
    5555      5.2)
Note: See TracChangeset for help on using the changeset viewer.