WordPress.org

Make WordPress Core

Changeset 43029


Ignore:
Timestamp:
04/29/2018 10:51:01 PM (2 years ago)
Author:
SergeyBiryukov
Message:

Plugins: Show the required PHP version in the plugin details view, if specified.

Props xkon.
Merges [42998] to the 4.9 branch.
Fixes #43650.

Location:
branches/4.9
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • branches/4.9

  • branches/4.9/src/wp-admin/includes/plugin-install.php

    r42524 r43029  
    585585                    <strong><?php _e( 'Requires WordPress Version:' ); ?></strong>
    586586                    <?php
    587                     /* translators: %s: WordPress version */
     587                    /* translators: %s: version number */
    588588                    printf( __( '%s or higher' ), $api->requires );
    589589                    ?>
     
    591591            <?php } if ( ! empty( $api->tested ) ) { ?>
    592592                <li><strong><?php _e( 'Compatible up to:' ); ?></strong> <?php echo $api->tested; ?></li>
     593            <?php } if ( ! empty( $api->requires_php ) ) { ?>
     594                <li>
     595                    <strong><?php _e( 'Requires PHP Version:' ); ?></strong>
     596                    <?php
     597                    /* translators: %s: version number */
     598                    printf( __( '%s or higher' ), $api->requires_php );
     599                    ?>
     600                </li>
    593601            <?php } if ( isset( $api->active_installs ) ) { ?>
    594602                <li><strong><?php _e( 'Active Installations:' ); ?></strong> <?php
Note: See TracChangeset for help on using the changeset viewer.