Make WordPress Core

Changeset 43321 for trunk/package.json


Ignore:
Timestamp:
05/27/2018 04:07:48 PM (6 years ago)
Author:
azaozz
Message:

Build tools: add check-node-version to check required Node.js and npm versions are installed.

Props netweb.
Fixes #44246.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package.json

    r43320 r43321  
    1515    "devDependencies": {
    1616        "autoprefixer": "^6.5.1",
     17        "check-node-version": "3.2.0",
    1718        "grunt": "~0.4.5",
    1819        "grunt-banner": "^0.6.0",
     
    5556        "twemoji": "2.5.1",
    5657        "underscore": "1.8.3"
     58    },
     59    "scripts": {
     60        "preinstall": "check-node-version  --node '>= 8.9.3' --npm '>= 6.1.0'"
    5761    }
    5862}
Note: See TracChangeset for help on using the changeset viewer.