WordPress.org

Make WordPress Core


Ignore:
Timestamp:
10/22/2018 04:49:24 AM (2 years ago)
Author:
pento
Message:

Build: Switch package.json to using tabs for indents.

Merges [42460] to the 5.0 branch.

Props netweb.
Fixes #43075.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/5.0/package.json

    r43719 r43782  
    11{
    2   "name": "WordPress",
    3   "version": "5.0.0",
    4   "description": "WordPress is web software you can use to create a beautiful website or blog.",
    5   "repository": {
    6     "type": "svn",
    7     "url": "https://develop.svn.wordpress.org/trunk"
    8   },
    9   "engines": {
    10     "node": "8.9.3",
    11     "npm": "6.1.0"
    12   },
    13   "author": "The WordPress Contributors",
    14   "license": "GPL-2.0+",
    15   "devDependencies": {
    16     "@wordpress/custom-templated-path-webpack-plugin": "^1.1.5",
    17     "@wordpress/library-export-default-webpack-plugin": "^1.0.4",
    18     "autoprefixer": "^9.1.5",
    19     "copy-webpack-plugin": "^4.5.2",
    20     "cssnano": "^4.1.4",
    21     "grunt": "~1.0.3",
    22     "grunt-banner": "^0.6.0",
    23     "grunt-contrib-clean": "~2.0.0",
    24     "grunt-contrib-compress": "~1.4.3",
    25     "grunt-contrib-concat": "~1.0.0",
    26     "grunt-contrib-copy": "~1.0.0",
    27     "grunt-contrib-cssmin": "~3.0.0",
    28     "grunt-contrib-imagemin": "~2.0.1",
    29     "grunt-contrib-jshint": "~2.0.0",
    30     "grunt-contrib-qunit": "^1.2.0",
    31     "grunt-contrib-uglify": "~2.0.0",
    32     "grunt-contrib-watch": "~1.1.0",
    33     "grunt-includes": "~1.1.0",
    34     "grunt-jsdoc": "^2.1.0",
    35     "grunt-jsvalidate": "~0.2.2",
    36     "grunt-legacy-util": "^1.1.1",
    37     "grunt-patch-wordpress": "~1.0.0",
    38     "grunt-postcss": "~0.9.0",
    39     "grunt-replace": "~1.0.1",
    40     "grunt-rtlcss": "~2.0.1",
    41     "grunt-sass": "~2.0.0",
    42     "grunt-webpack": "^3.0.2",
    43     "ink-docstrap": "^1.3.0",
    44     "matchdep": "~2.0.0",
    45     "source-map-loader": "^0.2.4",
    46     "uglify-js": "^3.4.9",
    47     "webpack": "^4.20.2",
    48     "webpack-dev-server": "^3.1.9",
    49     "webpack-livereload-plugin": "^2.1.1"
    50   },
    51   "dependencies": {
    52     "@babel/polyfill": "^7.0.0",
    53     "@wordpress/a11y": "^2.0.2",
    54     "@wordpress/api-fetch": "^2.0.2",
    55     "@wordpress/autop": "^2.0.2",
    56     "@wordpress/blob": "^2.0.2",
    57     "@wordpress/block-library": "^2.1.0",
    58     "@wordpress/block-serialization-default-parser": "^1.0.1",
    59     "@wordpress/blocks": "^4.0.1",
    60     "@wordpress/components": "^4.1.0",
    61     "@wordpress/compose": "^2.0.2",
    62     "@wordpress/core-data": "^2.0.2",
    63     "@wordpress/data": "^2.1.1",
    64     "@wordpress/date": "^2.0.2",
    65     "@wordpress/deprecated": "^2.0.2",
    66     "@wordpress/dom": "^2.0.2",
    67     "@wordpress/dom-ready": "^2.0.2",
    68     "@wordpress/edit-post": "^1.0.0",
    69     "@wordpress/editor": "^4.0.1",
    70     "@wordpress/element": "^2.1.1",
    71     "@wordpress/escape-html": "^1.0.0-beta.1",
    72     "@wordpress/hooks": "^2.0.2",
    73     "@wordpress/html-entities": "^2.0.2",
    74     "@wordpress/i18n": "^3.0.1",
    75     "@wordpress/is-shallow-equal": "^1.1.4",
    76     "@wordpress/keycodes": "^2.0.2",
    77     "@wordpress/list-reusable-blocks": "^1.1.0",
    78     "@wordpress/nux": "^2.0.1",
    79     "@wordpress/plugins": "^2.0.2",
    80     "@wordpress/redux-routine": "^3.0.1",
    81     "@wordpress/rich-text": "^1.0.0-beta.1",
    82     "@wordpress/shortcode": "^2.0.2",
    83     "@wordpress/token-list": "^1.0.2",
    84     "@wordpress/url": "^2.0.2",
    85     "@wordpress/viewport": "^2.0.2",
    86     "@wordpress/wordcount": "^2.0.2",
    87     "element-closest": "^2.0.2",
    88     "formdata-polyfill": "^3.0.12",
    89     "lodash": "^4.17.11",
    90     "moment": "^2.22.2",
    91     "polyfill-library": "^3.26.0-0",
    92     "react": "^16.5.2",
    93     "react-dom": "^16.5.2",
    94     "whatwg-fetch": "^3.0.0"
    95   }
     2    "name": "WordPress",
     3    "version": "5.0.0",
     4    "description": "WordPress is web software you can use to create a beautiful website or blog.",
     5    "repository": {
     6        "type": "svn",
     7        "url": "https://develop.svn.wordpress.org/trunk"
     8    },
     9    "engines": {
     10        "node": "8.9.3",
     11        "npm": "6.1.0"
     12    },
     13    "author": "The WordPress Contributors",
     14    "license": "GPL-2.0+",
     15    "devDependencies": {
     16        "@wordpress/custom-templated-path-webpack-plugin": "^1.1.5",
     17        "@wordpress/library-export-default-webpack-plugin": "^1.0.4",
     18        "autoprefixer": "^9.1.5",
     19        "copy-webpack-plugin": "^4.5.2",
     20        "cssnano": "^4.1.4",
     21        "grunt": "~1.0.3",
     22        "grunt-banner": "^0.6.0",
     23        "grunt-contrib-clean": "~2.0.0",
     24        "grunt-contrib-compress": "~1.4.3",
     25        "grunt-contrib-concat": "~1.0.0",
     26        "grunt-contrib-copy": "~1.0.0",
     27        "grunt-contrib-cssmin": "~3.0.0",
     28        "grunt-contrib-imagemin": "~2.0.1",
     29        "grunt-contrib-jshint": "~2.0.0",
     30        "grunt-contrib-qunit": "^1.2.0",
     31        "grunt-contrib-uglify": "~2.0.0",
     32        "grunt-contrib-watch": "~1.1.0",
     33        "grunt-includes": "~1.1.0",
     34        "grunt-jsdoc": "^2.1.0",
     35        "grunt-jsvalidate": "~0.2.2",
     36        "grunt-legacy-util": "^1.1.1",
     37        "grunt-patch-wordpress": "~1.0.0",
     38        "grunt-postcss": "~0.9.0",
     39        "grunt-replace": "~1.0.1",
     40        "grunt-rtlcss": "~2.0.1",
     41        "grunt-sass": "~2.0.0",
     42        "grunt-webpack": "^3.0.2",
     43        "ink-docstrap": "^1.3.0",
     44        "matchdep": "~2.0.0",
     45        "source-map-loader": "^0.2.4",
     46        "uglify-js": "^3.4.9",
     47        "webpack": "^4.20.2",
     48        "webpack-dev-server": "^3.1.9",
     49        "webpack-livereload-plugin": "^2.1.1"
     50    },
     51    "dependencies": {
     52        "@babel/polyfill": "^7.0.0",
     53        "@wordpress/a11y": "^2.0.2",
     54        "@wordpress/api-fetch": "^2.0.2",
     55        "@wordpress/autop": "^2.0.2",
     56        "@wordpress/blob": "^2.0.2",
     57        "@wordpress/block-library": "^2.1.0",
     58        "@wordpress/block-serialization-default-parser": "^1.0.1",
     59        "@wordpress/blocks": "^4.0.1",
     60        "@wordpress/components": "^4.1.0",
     61        "@wordpress/compose": "^2.0.2",
     62        "@wordpress/core-data": "^2.0.2",
     63        "@wordpress/data": "^2.1.1",
     64        "@wordpress/date": "^2.0.2",
     65        "@wordpress/deprecated": "^2.0.2",
     66        "@wordpress/dom": "^2.0.2",
     67        "@wordpress/dom-ready": "^2.0.2",
     68        "@wordpress/edit-post": "^1.0.0",
     69        "@wordpress/editor": "^4.0.1",
     70        "@wordpress/element": "^2.1.1",
     71        "@wordpress/escape-html": "^1.0.0-beta.1",
     72        "@wordpress/hooks": "^2.0.2",
     73        "@wordpress/html-entities": "^2.0.2",
     74        "@wordpress/i18n": "^3.0.1",
     75        "@wordpress/is-shallow-equal": "^1.1.4",
     76        "@wordpress/keycodes": "^2.0.2",
     77        "@wordpress/list-reusable-blocks": "^1.1.0",
     78        "@wordpress/nux": "^2.0.1",
     79        "@wordpress/plugins": "^2.0.2",
     80        "@wordpress/redux-routine": "^3.0.1",
     81        "@wordpress/rich-text": "^1.0.0-beta.1",
     82        "@wordpress/shortcode": "^2.0.2",
     83        "@wordpress/token-list": "^1.0.2",
     84        "@wordpress/url": "^2.0.2",
     85        "@wordpress/viewport": "^2.0.2",
     86        "@wordpress/wordcount": "^2.0.2",
     87        "element-closest": "^2.0.2",
     88        "formdata-polyfill": "^3.0.12",
     89        "lodash": "^4.17.11",
     90        "moment": "^2.22.2",
     91        "polyfill-library": "^3.26.0-0",
     92        "react": "^16.5.2",
     93        "react-dom": "^16.5.2",
     94        "whatwg-fetch": "^3.0.0"
     95    }
    9696}
Note: See TracChangeset for help on using the changeset viewer.