WordPress.org

Make WordPress Core


Ignore:
Timestamp:
11/16/2018 12:09:08 AM (11 months ago)
Author:
aduth
Message:

Block Editor: Update @wordpress dependencies to match Gutenberg 4.4.0

Updates packages: annotations, api-fetch, block-library, blocks, components, compose, core-data, data, date, edit-post, editor, element, format-library, i18n, list-reusable-blocks, notices, nux, plugins, rich-text, viewport

Updates changed dependencies in script-loader.php

Upgrades React from 16.5.2 to 16.6.3

See #45145

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/5.0/package.json

    r43891 r43903  
    5252        "@babel/polyfill": "^7.0.0",
    5353        "@wordpress/a11y": "^2.0.2",
    54         "@wordpress/annotations": "^1.0.0",
    55         "@wordpress/api-fetch": "^2.2.3",
     54        "@wordpress/annotations": "^1.0.1",
     55        "@wordpress/api-fetch": "^2.2.4",
    5656        "@wordpress/autop": "^2.0.2",
    5757        "@wordpress/blob": "^2.1.0",
    58         "@wordpress/block-library": "^2.2.3",
     58        "@wordpress/block-library": "^2.2.4",
    5959        "@wordpress/block-serialization-default-parser": "^2.0.0",
    60         "@wordpress/blocks": "^5.3.1",
    61         "@wordpress/components": "^6.0.1",
    62         "@wordpress/compose": "^2.1.2",
    63         "@wordpress/core-data": "^2.0.12",
    64         "@wordpress/data": "^3.1.2",
    65         "@wordpress/date": "^2.2.1",
     60        "@wordpress/blocks": "^6.0.0",
     61        "@wordpress/components": "^6.0.2",
     62        "@wordpress/compose": "^3.0.0",
     63        "@wordpress/core-data": "^2.0.13",
     64        "@wordpress/data": "^4.0.0",
     65        "@wordpress/date": "^3.0.0",
    6666        "@wordpress/deprecated": "^2.0.3",
    6767        "@wordpress/dom": "^2.0.6",
    6868        "@wordpress/dom-ready": "^2.0.2",
    69         "@wordpress/edit-post": "^3.0.1",
    70         "@wordpress/editor": "^7.0.1",
    71         "@wordpress/element": "^2.1.7",
     69        "@wordpress/edit-post": "^3.0.2",
     70        "@wordpress/editor": "^8.0.0",
     71        "@wordpress/element": "^2.1.8",
    7272        "@wordpress/escape-html": "^1.0.1",
    73         "@wordpress/format-library": "^1.2.1",
     73        "@wordpress/format-library": "^1.2.2",
    7474        "@wordpress/hooks": "^2.0.3",
    7575        "@wordpress/html-entities": "^2.0.2",
    76         "@wordpress/i18n": "^3.0.1",
     76        "@wordpress/i18n": "^3.1.0",
    7777        "@wordpress/is-shallow-equal": "^1.1.4",
    7878        "@wordpress/keycodes": "^2.0.3",
    79         "@wordpress/list-reusable-blocks": "^1.1.11",
    80         "@wordpress/notices": "^1.0.4",
    81         "@wordpress/nux": "^2.0.13",
    82         "@wordpress/plugins": "^2.0.8",
     79        "@wordpress/list-reusable-blocks": "^1.1.12",
     80        "@wordpress/notices": "^1.0.5",
     81        "@wordpress/nux": "^3.0.0",
     82        "@wordpress/plugins": "^2.0.9",
    8383        "@wordpress/redux-routine": "^3.0.3",
    84         "@wordpress/rich-text": "^2.0.4",
     84        "@wordpress/rich-text": "^3.0.0",
    8585        "@wordpress/shortcode": "^2.0.2",
    8686        "@wordpress/token-list": "^1.0.2",
    8787        "@wordpress/url": "^2.3.0",
    88         "@wordpress/viewport": "^2.0.10",
     88        "@wordpress/viewport": "^2.0.11",
    8989        "@wordpress/wordcount": "^2.0.3",
    9090        "element-closest": "^2.0.2",
     
    9393        "moment": "^2.22.2",
    9494        "polyfill-library": "^3.26.0-0",
    95         "react": "^16.5.2",
    96         "react-dom": "^16.5.2",
     95        "react": "^16.6.3",
     96        "react-dom": "^16.6.3",
    9797        "whatwg-fetch": "^3.0.0"
    9898    },
Note: See TracChangeset for help on using the changeset viewer.