WordPress.org

Make WordPress Core


Ignore:
Timestamp:
11/16/2018 12:09:08 AM (11 months ago)
Author:
aduth
Message:

Block Editor: Update @wordpress dependencies to match Gutenberg 4.4.0

Updates packages: annotations, api-fetch, block-library, blocks, components, compose, core-data, data, date, edit-post, editor, element, format-library, i18n, list-reusable-blocks, notices, nux, plugins, rich-text, viewport

Updates changed dependencies in script-loader.php

Upgrades React from 16.5.2 to 16.6.3

See #45145

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/5.0/src/wp-includes/script-loader.php

    r43901 r43903  
    7878
    7979    $vendor_scripts = array(
    80         'react',
     80        'react' => array( 'wp-polyfill' ),
    8181        'react-dom' => array( 'react' ),
    8282        'moment',
     
    184184            'wp-element',
    185185            'wp-hooks',
     186            'wp-html-entities',
    186187            'wp-i18n',
    187188            'wp-is-shallow-equal',
     
    235236        'compose' => array(
    236237            'lodash',
    237             'wp-deprecated',
    238238            'wp-element',
    239239            'wp-is-shallow-equal',
     
    244244            'lodash',
    245245            'wp-compose',
    246             'wp-deprecated',
    247246            'wp-element',
    248247            'wp-is-shallow-equal',
     
    349348            'wp-compose',
    350349            'wp-data',
    351             'wp-deprecated',
    352350            'wp-i18n',
    353351            'wp-polyfill',
     
    360358            'wp-blocks',
    361359            'wp-data',
    362             'wp-deprecated',
    363360            'wp-escape-html',
    364361            'wp-polyfill',
Note: See TracChangeset for help on using the changeset viewer.