WordPress.org

Make WordPress Core

Changeset 44281


Ignore:
Timestamp:
12/17/2018 09:58:12 PM (3 years ago)
Author:
desrosj
Message:

Block Editor: Update @wordpress package dependencies.

Updates the following packages:

block-library, block-serialization-default-parser, block-serialization-spec-parser, blocks, edit-post, editor, format-library.

Merges [43955] to trunk.

Props youknowriad.

Fixes #45145.

Location:
trunk
Files:
5 edited

Legend:

Unmodified
Added
Removed
  • trunk

  • trunk/package-lock.json

    r44273 r44281  
    287287        },
    288288        "@wordpress/block-library": {
    289             "version": "2.2.8",
    290             "resolved": "https://registry.npmjs.org/@wordpress/block-library/-/block-library-2.2.8.tgz",
    291             "integrity": "sha512-86DiBPFQwGDWf/s4OwmTp2q+VoeNhmW1OQXu/on+c5MHgJh7W2uFasO4bhmz31+U9KwAFHQr3pCcxaasdP17vQ==",
     289            "version": "2.2.9",
     290            "resolved": "https://registry.npmjs.org/@wordpress/block-library/-/block-library-2.2.9.tgz",
     291            "integrity": "sha512-Do/3f1S6uPOywSSiCyeLW6//DEIy7cAyBIdtxcl1CssfpwCPiDbXq5OpyRf94FKV4J1C0qwJfF604IdcsCmsjw==",
    292292            "requires": {
    293293                "@babel/runtime": "^7.0.0",
    294294                "@wordpress/autop": "^2.0.2",
    295295                "@wordpress/blob": "^2.1.0",
    296                 "@wordpress/blocks": "^6.0.2",
     296                "@wordpress/blocks": "^6.0.3",
    297297                "@wordpress/components": "^7.0.3",
    298298                "@wordpress/compose": "^3.0.0",
     
    300300                "@wordpress/data": "^4.0.1",
    301301                "@wordpress/deprecated": "^2.0.3",
    302                 "@wordpress/editor": "^9.0.3",
     302                "@wordpress/editor": "^9.0.4",
    303303                "@wordpress/element": "^2.1.8",
    304304                "@wordpress/html-entities": "^2.0.3",
     
    323323        },
    324324        "@wordpress/block-serialization-default-parser": {
    325             "version": "2.0.0",
    326             "resolved": "https://registry.npmjs.org/@wordpress/block-serialization-default-parser/-/block-serialization-default-parser-2.0.0.tgz",
    327             "integrity": "sha512-WPQuQ2IsUOG9wMTst8CYW8c5NMM3iatTW2FinfZrHtH9R1g9qdQPt5Wv56U7eMeDACVOj35jG2oJtZCRaDyL7A==",
     325            "version": "2.0.1",
     326            "resolved": "https://registry.npmjs.org/@wordpress/block-serialization-default-parser/-/block-serialization-default-parser-2.0.1.tgz",
     327            "integrity": "sha512-Wd4yC9NgakDv39bPskA56GSGprZ5kXuhDff3hLR2HpOYS2TPHgT06UsfVfO1tJBOxrqcS/AHVj7FEFZqyyKPNg==",
    328328            "requires": {
    329329                "@babel/runtime": "^7.0.0"
     
    331331        },
    332332        "@wordpress/block-serialization-spec-parser": {
    333             "version": "2.0.0",
    334             "resolved": "https://registry.npmjs.org/@wordpress/block-serialization-spec-parser/-/block-serialization-spec-parser-2.0.0.tgz",
    335             "integrity": "sha512-l5N0o2Tkc4IcDhhMfX2W3KuEV/4F7TeitJEDtBpLYf7eRMIn3Uh6l5rPDmmuTDv7UFlMWTiA8z/oCpl13ZyBOw=="
     333            "version": "2.0.1",
     334            "resolved": "https://registry.npmjs.org/@wordpress/block-serialization-spec-parser/-/block-serialization-spec-parser-2.0.1.tgz",
     335            "integrity": "sha512-9bhi2/hThAH8MbFAalI3UMZiKmUih8Az5ZFRzZy9E+EO4BYW479DFU5l/jSelDh3fPhsPza9UZ0so3IrqqoCzg=="
    336336        },
    337337        "@wordpress/blocks": {
    338             "version": "6.0.2",
    339             "resolved": "https://registry.npmjs.org/@wordpress/blocks/-/blocks-6.0.2.tgz",
    340             "integrity": "sha512-Y9cIbxXnATT6NPBbT969awm/5iLL/fRYoQ2a0xoqqHdcI8kxPbMv2TdAE8RaM8eeYL17t6CmWdfP+jkAIVGMGg==",
     338            "version": "6.0.3",
     339            "resolved": "https://registry.npmjs.org/@wordpress/blocks/-/blocks-6.0.3.tgz",
     340            "integrity": "sha512-jBk9xa87b9xgizVXBBnCYMDju0Q871JyeSCwJyUvd77flrym7BjfNIIWVnwOlLxUYc6BeHxZCAi+JzybHLlvFA==",
    341341            "requires": {
    342342                "@babel/runtime": "^7.0.0",
    343343                "@wordpress/autop": "^2.0.2",
    344344                "@wordpress/blob": "^2.1.0",
    345                 "@wordpress/block-serialization-default-parser": "^2.0.0",
    346                 "@wordpress/block-serialization-spec-parser": "^2.0.0",
     345                "@wordpress/block-serialization-default-parser": "^2.0.1",
     346                "@wordpress/block-serialization-spec-parser": "^2.0.1",
    347347                "@wordpress/data": "^4.0.1",
    348348                "@wordpress/dom": "^2.0.7",
     
    484484        },
    485485        "@wordpress/edit-post": {
    486             "version": "3.1.3",
    487             "resolved": "https://registry.npmjs.org/@wordpress/edit-post/-/edit-post-3.1.3.tgz",
    488             "integrity": "sha512-bA9OIkzInCLvf2YB4b6H0Ubghmv+AjOrCpZcp/5sdWLAg7hE6ZzZZ5Pz/2o5bBd+mTkalALJFMxgy7DKvH3WgQ==",
     486            "version": "3.1.4",
     487            "resolved": "https://registry.npmjs.org/@wordpress/edit-post/-/edit-post-3.1.4.tgz",
     488            "integrity": "sha512-xZZ1x+JfMLTgCZkkdaJeYdsdEVQ+MkbRtweSdqfm4p4zdyId8wTg/n/ccqAAhFnQjoTufEkkchzRmmnoHozrcg==",
    489489            "requires": {
    490490                "@babel/runtime": "^7.0.0",
    491491                "@wordpress/a11y": "^2.0.2",
    492492                "@wordpress/api-fetch": "^2.2.5",
    493                 "@wordpress/block-library": "^2.2.8",
    494                 "@wordpress/blocks": "^6.0.2",
     493                "@wordpress/block-library": "^2.2.9",
     494                "@wordpress/blocks": "^6.0.3",
    495495                "@wordpress/components": "^7.0.3",
    496496                "@wordpress/compose": "^3.0.0",
    497497                "@wordpress/core-data": "^2.0.14",
    498498                "@wordpress/data": "^4.0.1",
    499                 "@wordpress/editor": "^9.0.3",
     499                "@wordpress/editor": "^9.0.4",
    500500                "@wordpress/element": "^2.1.8",
    501                 "@wordpress/format-library": "^1.2.6",
     501                "@wordpress/format-library": "^1.2.7",
    502502                "@wordpress/hooks": "^2.0.3",
    503503                "@wordpress/i18n": "^3.1.0",
     
    513513        },
    514514        "@wordpress/editor": {
    515             "version": "9.0.3",
    516             "resolved": "https://registry.npmjs.org/@wordpress/editor/-/editor-9.0.3.tgz",
    517             "integrity": "sha512-Iz2B2JccsluiV0CdIkeH7sdl+3JcM7u9OqQSRC+0G2gfq8c09c98BE9myRUN16EVvL6zf025DzRU3hSx9r3AbQ==",
     515            "version": "9.0.4",
     516            "resolved": "https://registry.npmjs.org/@wordpress/editor/-/editor-9.0.4.tgz",
     517            "integrity": "sha512-adLq0C0DZFz5R1TNzqRttmcEHXz9Nv4VIBxyqFQbubfMAzq6LKv44YxNw0t9Pg2cZQr4V5gbu214H/0C67PFTQ==",
    518518            "requires": {
    519519                "@babel/runtime": "^7.0.0",
     
    521521                "@wordpress/api-fetch": "^2.2.5",
    522522                "@wordpress/blob": "^2.1.0",
    523                 "@wordpress/blocks": "^6.0.2",
     523                "@wordpress/blocks": "^6.0.3",
    524524                "@wordpress/components": "^7.0.3",
    525525                "@wordpress/compose": "^3.0.0",
     
    618618        },
    619619        "@wordpress/format-library": {
    620             "version": "1.2.6",
    621             "resolved": "https://registry.npmjs.org/@wordpress/format-library/-/format-library-1.2.6.tgz",
    622             "integrity": "sha512-8GkrMRSZ287qotsYzJh0kzDRjDAYJLicwbSRSv4AR2+4dSW6ZX1CK2jt/ihxg5cbqxMitPPTqRA0PmUk+AtdDA==",
     620            "version": "1.2.7",
     621            "resolved": "https://registry.npmjs.org/@wordpress/format-library/-/format-library-1.2.7.tgz",
     622            "integrity": "sha512-lVsltV1vS9BW+rHxb0ue+/z5ghvytAixVKCkwMaEEnc4qYYo4nzfsXTNCqpgxyQkpgH34j96psPD/34+os0ALg==",
    623623            "requires": {
    624624                "@babel/runtime": "^7.0.0",
    625625                "@wordpress/components": "^7.0.3",
    626626                "@wordpress/dom": "^2.0.7",
    627                 "@wordpress/editor": "^9.0.3",
     627                "@wordpress/editor": "^9.0.4",
    628628                "@wordpress/element": "^2.1.8",
    629629                "@wordpress/i18n": "^3.1.0",
  • trunk/package.json

    r44273 r44281  
    6161        "@wordpress/autop": "^2.0.2",
    6262        "@wordpress/blob": "^2.1.0",
    63         "@wordpress/block-library": "^2.2.8",
    64         "@wordpress/block-serialization-default-parser": "^2.0.0",
    65         "@wordpress/blocks": "^6.0.2",
     63        "@wordpress/block-library": "^2.2.9",
     64        "@wordpress/block-serialization-default-parser": "^2.0.1",
     65        "@wordpress/blocks": "^6.0.3",
    6666        "@wordpress/components": "^7.0.3",
    6767        "@wordpress/compose": "^3.0.0",
     
    7272        "@wordpress/dom": "^2.0.7",
    7373        "@wordpress/dom-ready": "^2.0.2",
    74         "@wordpress/edit-post": "^3.1.3",
    75         "@wordpress/editor": "^9.0.3",
     74        "@wordpress/edit-post": "^3.1.4",
     75        "@wordpress/editor": "^9.0.4",
    7676        "@wordpress/element": "^2.1.8",
    7777        "@wordpress/escape-html": "^1.0.1",
    78         "@wordpress/format-library": "^1.2.6",
     78        "@wordpress/format-library": "^1.2.7",
    7979        "@wordpress/hooks": "^2.0.3",
    8080        "@wordpress/html-entities": "^2.0.3",
  • trunk/src/wp-includes/class-wp-block-parser.php

    r44266 r44281  
    365365     * @internal
    366366     * @since 3.8.0
     367     * @since 4.6.1 fixed a bug in attribute parsing which caused catastrophic backtracking on invalid block comments
    367368     * @return array
    368369     */
     
    379380         */
    380381        $has_match = preg_match(
    381             '/<!--\s+(?<closer>\/)?wp:(?<namespace>[a-z][a-z0-9_-]*\/)?(?<name>[a-z][a-z0-9_-]*)\s+(?<attrs>{(?:[^}]+|}+(?=})|(?!}\s+-->).)*?}\s+)?(?<void>\/)?-->/s',
     382            '/<!--\s+(?<closer>\/)?wp:(?<namespace>[a-z][a-z0-9_-]*\/)?(?<name>[a-z][a-z0-9_-]*)\s+(?<attrs>{(?:(?:[^}]+|}+(?=})|(?!}\s+\/?-->).)*+)?}\s+)?(?<void>\/)?-->/s',
    382383            $this->document,
    383384            $matches,
     
    385386            $this->offset
    386387        );
     388
     389        // if we get here we probably have catastrophic backtracking or out-of-memory in the PCRE
     390        if ( false === $has_match ) {
     391            return array( 'no-more-tokens', null, null, null, null );
     392        }
    387393
    388394        // we have no more tokens
  • trunk/src/wp-includes/script-loader.php

    r44277 r44281  
    213213        'autop'                              => '2.0.2',
    214214        'blob'                               => '2.1.0',
    215         'block-library'                      => '2.2.8',
    216         'block-serialization-default-parser' => '2.0.0',
    217         'blocks'                             => '6.0.2',
     215        'block-library'                      => '2.2.9',
     216        'block-serialization-default-parser' => '2.0.1',
     217        'blocks'                             => '6.0.3',
    218218        'components'                         => '7.0.3',
    219219        'compose'                            => '3.0.0',
     
    224224        'dom'                                => '2.0.7',
    225225        'dom-ready'                          => '2.0.2',
    226         'edit-post'                          => '3.1.3',
    227         'editor'                             => '9.0.3',
     226        'edit-post'                          => '3.1.4',
     227        'editor'                             => '9.0.4',
    228228        'element'                            => '2.1.8',
    229229        'escape-html'                        => '1.0.1',
    230         'format-library'                     => '1.2.6',
     230        'format-library'                     => '1.2.7',
    231231        'hooks'                              => '2.0.3',
    232232        'html-entities'                      => '2.0.3',
Note: See TracChangeset for help on using the changeset viewer.