WordPress.org

Make WordPress Core

Changeset 44808 for trunk/package.json


Ignore:
Timestamp:
03/07/2019 09:08:38 AM (21 months ago)
Author:
youknowriad
Message:

Block Editor: Update the WordPress Packages from Gutenberg 5.2.

Updated Packages:

  • @wordpress/a11y@2.1.0
  • @wordpress/annotations@1.1.0
  • @wordpress/api-fetch@3.0.0
  • @wordpress/autop@2.1.0
  • @wordpress/babel-plugin-import-jsx-pragma@2.0.0
  • @wordpress/babel-plugin-makepot@3.0.0
  • @wordpress/babel-preset-default@4.0.0
  • @wordpress/blob@2.2.0
  • @wordpress/block-editor@1.0.0
  • @wordpress/block-library@2.3.0
  • @wordpress/block-serialization-default-parser@3.0.0
  • @wordpress/block-serialization-spec-parser@3.0.0
  • @wordpress/blocks@6.1.0
  • @wordpress/browserslist-config@2.3.0
  • @wordpress/components@7.1.0
  • @wordpress/compose@3.1.0
  • @wordpress/core-data@2.1.0
  • @wordpress/custom-templated-path-webpack-plugin@1.2.0
  • @wordpress/data@4.3.0
  • @wordpress/date@3.1.0
  • @wordpress/deprecated@2.1.0
  • @wordpress/docgen@1.0.0
  • @wordpress/dom-ready@2.1.0
  • @wordpress/dom@2.1.0
  • @wordpress/e2e-test-utils@1.0.0
  • @wordpress/e2e-tests@1.0.0
  • @wordpress/edit-post@3.2.0
  • @wordpress/editor@9.1.0
  • @wordpress/element@2.2.0
  • @wordpress/escape-html@1.1.0
  • @wordpress/eslint-plugin@2.0.0
  • @wordpress/format-library@1.3.0
  • @wordpress/hooks@2.1.0
  • @wordpress/html-entities@2.1.0
  • @wordpress/i18n@3.2.0
  • @wordpress/is-shallow-equal@1.2.0
  • @wordpress/jest-console@3.0.0
  • @wordpress/jest-preset-default@4.0.0
  • @wordpress/jest-puppeteer-axe@1.0.0
  • @wordpress/keycodes@2.1.0
  • @wordpress/library-export-default-webpack-plugin@1.1.0
  • @wordpress/list-reusable-blocks@1.2.0
  • @wordpress/notices@1.2.0
  • @wordpress/npm-package-json-lint-config@1.2.0
  • @wordpress/nux@3.1.0
  • @wordpress/plugins@2.1.0
  • @wordpress/postcss-themes@2.0.0
  • @wordpress/priority-queue@1.0.0
  • @wordpress/redux-routine@3.1.0
  • @wordpress/rich-text@3.1.0
  • @wordpress/scripts@3.0.0
  • @wordpress/shortcode@2.1.0
  • @wordpress/token-list@1.2.0
  • @wordpress/url@2.4.0
  • @wordpress/viewport@2.2.0
  • @wordpress/wordcount@2.1.0

This also includes the update to the scripts dependencies and the new widgets php files.

Props iseulde.
Fixes #46429.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package.json

    r44746 r44808  
    1414    "license": "GPL-2.0-or-later",
    1515    "devDependencies": {
    16         "@wordpress/custom-templated-path-webpack-plugin": "1.1.6",
    17         "@wordpress/library-export-default-webpack-plugin": "1.0.5",
     16        "@wordpress/custom-templated-path-webpack-plugin": "1.2.0",
     17        "@wordpress/library-export-default-webpack-plugin": "1.1.0",
    1818        "autoprefixer": "9.4.7",
    1919        "check-node-version": "3.2.0",
     
    5555    "dependencies": {
    5656        "@babel/polyfill": "7.2.5",
    57         "@wordpress/a11y": "^2.0.2",
    58         "@wordpress/annotations": "1.0.8",
    59         "@wordpress/api-fetch": "^2.2.8",
    60         "@wordpress/autop": "^2.0.2",
    61         "@wordpress/blob": "^2.1.0",
    62         "@wordpress/block-library": "2.2.16",
    63         "@wordpress/block-serialization-default-parser": "^2.0.5",
    64         "@wordpress/blocks": "^6.0.7",
    65         "@wordpress/components": "7.0.8",
    66         "@wordpress/compose": "^3.0.1",
    67         "@wordpress/core-data": "^2.0.17",
    68         "@wordpress/data": "^4.2.1",
    69         "@wordpress/date": "^3.0.1",
    70         "@wordpress/deprecated": "^2.0.5",
    71         "@wordpress/dom": "^2.0.8",
    72         "@wordpress/dom-ready": "^2.0.2",
    73         "@wordpress/edit-post": "3.1.11",
    74         "@wordpress/editor": "9.0.11",
    75         "@wordpress/element": "^2.1.9",
    76         "@wordpress/escape-html": "^1.0.1",
    77         "@wordpress/format-library": "1.2.14",
    78         "@wordpress/hooks": "^2.0.5",
    79         "@wordpress/html-entities": "^2.0.4",
    80         "@wordpress/i18n": "^3.1.1",
    81         "@wordpress/is-shallow-equal": "^1.1.5",
    82         "@wordpress/keycodes": "^2.0.6",
    83         "@wordpress/list-reusable-blocks": "1.1.21",
    84         "@wordpress/notices": "^1.1.3",
    85         "@wordpress/nux": "3.0.9",
    86         "@wordpress/plugins": "^2.0.11",
    87         "@wordpress/redux-routine": "^3.0.4",
    88         "@wordpress/rich-text": "3.0.7",
    89         "@wordpress/shortcode": "^2.0.2",
    90         "@wordpress/token-list": "^1.1.0",
    91         "@wordpress/url": "^2.3.3",
    92         "@wordpress/viewport": "^2.1.1",
    93         "@wordpress/wordcount": "^2.0.3",
     57        "@wordpress/a11y": "^2.1.0",
     58        "@wordpress/annotations": "^1.1.0",
     59        "@wordpress/api-fetch": "^3.0.0",
     60        "@wordpress/autop": "^2.1.0",
     61        "@wordpress/blob": "^2.2.0",
     62        "@wordpress/block-editor": "^1.0.0",
     63        "@wordpress/block-library": "^2.3.0",
     64        "@wordpress/block-serialization-default-parser": "^3.0.0",
     65        "@wordpress/blocks": "^6.1.0",
     66        "@wordpress/components": "^7.1.0",
     67        "@wordpress/compose": "^3.1.0",
     68        "@wordpress/core-data": "^2.1.0",
     69        "@wordpress/data": "^4.3.0",
     70        "@wordpress/date": "^3.1.0",
     71        "@wordpress/deprecated": "^2.1.0",
     72        "@wordpress/dom": "^2.1.0",
     73        "@wordpress/dom-ready": "^2.1.0",
     74        "@wordpress/edit-post": "^3.2.0",
     75        "@wordpress/editor": "^9.1.0",
     76        "@wordpress/element": "^2.2.0",
     77        "@wordpress/escape-html": "^1.1.0",
     78        "@wordpress/format-library": "^1.3.0",
     79        "@wordpress/hooks": "^2.1.0",
     80        "@wordpress/html-entities": "^2.1.0",
     81        "@wordpress/i18n": "^3.2.0",
     82        "@wordpress/is-shallow-equal": "^1.2.0",
     83        "@wordpress/keycodes": "^2.1.0",
     84        "@wordpress/list-reusable-blocks": "^1.2.0",
     85        "@wordpress/notices": "^1.2.0",
     86        "@wordpress/nux": "^3.1.0",
     87        "@wordpress/plugins": "^2.1.0",
     88        "@wordpress/priority-queue": "^1.0.0",
     89        "@wordpress/redux-routine": "^3.1.0",
     90        "@wordpress/rich-text": "^3.1.0",
     91        "@wordpress/shortcode": "^2.1.0",
     92        "@wordpress/token-list": "^1.2.0",
     93        "@wordpress/url": "^2.4.0",
     94        "@wordpress/viewport": "^2.2.0",
     95        "@wordpress/wordcount": "^2.1.0",
    9496        "backbone": "1.3.3",
    9597        "element-closest": "^2.0.2",
Note: See TracChangeset for help on using the changeset viewer.