WordPress.org

Make WordPress Core


Ignore:
Timestamp:
03/07/2019 09:08:38 AM (21 months ago)
Author:
youknowriad
Message:

Block Editor: Update the WordPress Packages from Gutenberg 5.2.

Updated Packages:

  • @wordpress/a11y@2.1.0
  • @wordpress/annotations@1.1.0
  • @wordpress/api-fetch@3.0.0
  • @wordpress/autop@2.1.0
  • @wordpress/babel-plugin-import-jsx-pragma@2.0.0
  • @wordpress/babel-plugin-makepot@3.0.0
  • @wordpress/babel-preset-default@4.0.0
  • @wordpress/blob@2.2.0
  • @wordpress/block-editor@1.0.0
  • @wordpress/block-library@2.3.0
  • @wordpress/block-serialization-default-parser@3.0.0
  • @wordpress/block-serialization-spec-parser@3.0.0
  • @wordpress/blocks@6.1.0
  • @wordpress/browserslist-config@2.3.0
  • @wordpress/components@7.1.0
  • @wordpress/compose@3.1.0
  • @wordpress/core-data@2.1.0
  • @wordpress/custom-templated-path-webpack-plugin@1.2.0
  • @wordpress/data@4.3.0
  • @wordpress/date@3.1.0
  • @wordpress/deprecated@2.1.0
  • @wordpress/docgen@1.0.0
  • @wordpress/dom-ready@2.1.0
  • @wordpress/dom@2.1.0
  • @wordpress/e2e-test-utils@1.0.0
  • @wordpress/e2e-tests@1.0.0
  • @wordpress/edit-post@3.2.0
  • @wordpress/editor@9.1.0
  • @wordpress/element@2.2.0
  • @wordpress/escape-html@1.1.0
  • @wordpress/eslint-plugin@2.0.0
  • @wordpress/format-library@1.3.0
  • @wordpress/hooks@2.1.0
  • @wordpress/html-entities@2.1.0
  • @wordpress/i18n@3.2.0
  • @wordpress/is-shallow-equal@1.2.0
  • @wordpress/jest-console@3.0.0
  • @wordpress/jest-preset-default@4.0.0
  • @wordpress/jest-puppeteer-axe@1.0.0
  • @wordpress/keycodes@2.1.0
  • @wordpress/library-export-default-webpack-plugin@1.1.0
  • @wordpress/list-reusable-blocks@1.2.0
  • @wordpress/notices@1.2.0
  • @wordpress/npm-package-json-lint-config@1.2.0
  • @wordpress/nux@3.1.0
  • @wordpress/plugins@2.1.0
  • @wordpress/postcss-themes@2.0.0
  • @wordpress/priority-queue@1.0.0
  • @wordpress/redux-routine@3.1.0
  • @wordpress/rich-text@3.1.0
  • @wordpress/scripts@3.0.0
  • @wordpress/shortcode@2.1.0
  • @wordpress/token-list@1.2.0
  • @wordpress/url@2.4.0
  • @wordpress/viewport@2.2.0
  • @wordpress/wordcount@2.1.0

This also includes the update to the scripts dependencies and the new widgets php files.

Props iseulde.
Fixes #46429.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-includes/script-loader.php

    r44762 r44808  
    225225
    226226    $packages_versions = array(
    227         'api-fetch'                          => '2.2.8',
    228         'a11y'                               => '2.0.2',
    229         'annotations'                        => '1.0.8',
    230         'autop'                              => '2.0.2',
    231         'blob'                               => '2.1.0',
    232         'block-library'                      => '2.2.16',
    233         'block-serialization-default-parser' => '2.0.5',
    234         'blocks'                             => '6.0.6',
    235         'components'                         => '7.0.8',
    236         'compose'                            => '3.0.1',
    237         'core-data'                          => '2.0.17',
    238         'data'                               => '4.2.1',
    239         'date'                               => '3.0.1',
    240         'deprecated'                         => '2.0.5',
    241         'dom'                                => '2.0.8',
    242         'dom-ready'                          => '2.0.2',
    243         'edit-post'                          => '3.1.11',
    244         'editor'                             => '9.0.11',
    245         'element'                            => '2.1.9',
    246         'escape-html'                        => '1.0.1',
    247         'format-library'                     => '1.2.14',
    248         'hooks'                              => '2.0.5',
    249         'html-entities'                      => '2.0.4',
    250         'i18n'                               => '3.1.1',
    251         'is-shallow-equal'                   => '1.1.5',
    252         'keycodes'                           => '2.0.6',
    253         'list-reusable-blocks'               => '1.1.21',
    254         'notices'                            => '1.1.3',
    255         'nux'                                => '3.0.9',
    256         'plugins'                            => '2.0.10',
    257         'redux-routine'                      => '3.0.4',
    258         'rich-text'                          => '3.0.7',
    259         'shortcode'                          => '2.0.2',
    260         'token-list'                         => '1.1.0',
    261         'url'                                => '2.3.3',
    262         'viewport'                           => '2.1.1',
    263         'wordcount'                          => '2.0.3',
     227        'a11y'                               => '2.1.0',
     228        'annotations'                        => '1.1.0',
     229        'api-fetch'                          => '3.0.0',
     230        'autop'                              => '2.1.0',
     231        'blob'                               => '2.2.0',
     232        'block-editor'                       => '1.0.0',
     233        'block-library'                      => '2.3.0',
     234        'block-serialization-default-parser' => '3.0.0',
     235        'blocks'                             => '6.1.0',
     236        'components'                         => '7.1.0',
     237        'compose'                            => '3.1.0',
     238        'core-data'                          => '2.1.0',
     239        'data'                               => '4.3.0',
     240        'date'                               => '3.1.0',
     241        'deprecated'                         => '2.1.0',
     242        'dom'                                => '2.1.0',
     243        'dom-ready'                          => '2.1.0',
     244        'edit-post'                          => '3.2.0',
     245        'editor'                             => '9.1.0',
     246        'element'                            => '2.2.0',
     247        'escape-html'                        => '1.1.0',
     248        'format-library'                     => '1.3.0',
     249        'hooks'                              => '2.1.0',
     250        'html-entities'                      => '2.1.0',
     251        'i18n'                               => '3.2.0',
     252        'is-shallow-equal'                   => '1.2.0',
     253        'keycodes'                           => '2.1.0',
     254        'list-reusable-blocks'               => '1.2.0',
     255        'notices'                            => '1.2.0',
     256        'nux'                                => '3.1.0',
     257        'plugins'                            => '2.1.0',
     258        'priority-queue'                     => '1.0.0',
     259        'redux-routine'                      => '3.1.0',
     260        'rich-text'                          => '3.1.0',
     261        'shortcode'                          => '2.1.0',
     262        'token-list'                         => '1.2.0',
     263        'url'                                => '2.4.0',
     264        'viewport'                           => '2.2.0',
     265        'wordcount'                          => '2.1.0',
    264266    );
    265267
    266268    $packages_dependencies = array(
    267         'api-fetch'                          => array( 'wp-polyfill', 'wp-hooks', 'wp-i18n', 'wp-url' ),
     269        'api-fetch'                          => array( 'wp-polyfill', 'wp-i18n', 'wp-url' ),
    268270        'a11y'                               => array( 'wp-dom-ready', 'wp-polyfill' ),
    269271        'annotations'                        => array(
     
    297299            'wp-autop',
    298300            'wp-blob',
     301            'wp-block-editor',
    299302            'wp-blocks',
    300303            'wp-components',
     
    314317        ),
    315318        'block-serialization-default-parser' => array(),
     319        'block-editor'                       => array(
     320            'lodash',
     321            'wp-blocks',
     322            'wp-compose',
     323            'wp-components',
     324            'wp-data',
     325            'wp-element',
     326            'wp-i18n',
     327        ),
    316328        'components'                         => array(
    317329            'lodash',
     
    337349            'wp-polyfill',
    338350        ),
    339         'core-data'                          => array( 'wp-data', 'wp-api-fetch', 'wp-polyfill', 'wp-url', 'lodash' ),
     351        'core-data'                          => array(
     352            'lodash',
     353            'wp-api-fetch',
     354            'wp-data',
     355            'wp-deprecated',
     356            'wp-polyfill',
     357            'wp-url',
     358        ),
    340359        'data'                               => array(
    341360            'lodash',
     
    344363            'wp-is-shallow-equal',
    345364            'wp-polyfill',
     365            'wp-priority-queue',
    346366            'wp-redux-routine',
    347367        ),
    348368        'date'                               => array( 'moment', 'wp-polyfill' ),
    349369        'deprecated'                         => array( 'wp-polyfill', 'wp-hooks' ),
    350         'dom'                                => array( 'lodash', 'wp-polyfill', 'wp-tinymce' ),
     370        'dom'                                => array( 'lodash', 'wp-polyfill' ),
    351371        'dom-ready'                          => array( 'wp-polyfill' ),
    352372        'edit-post'                          => array(
     
    358378            'wp-a11y',
    359379            'wp-api-fetch',
     380            'wp-block-editor',
    360381            'wp-block-library',
    361382            'wp-blocks',
     
    378399        ),
    379400        'editor'                             => array(
    380             'jquery',
    381401            'lodash',
    382402            'wp-a11y',
    383403            'wp-api-fetch',
    384404            'wp-blob',
     405            'wp-block-editor',
    385406            'wp-blocks',
    386407            'wp-components',
     
    400421            'wp-nux',
    401422            'wp-polyfill',
    402             'wp-tinymce',
    403423            'wp-token-list',
    404424            'wp-url',
     
    411431        'format-library'                     => array(
    412432            'wp-components',
    413             'wp-dom',
    414433            'wp-editor',
    415434            'wp-element',
     
    451470        ),
    452471        'plugins'                            => array( 'lodash', 'wp-compose', 'wp-element', 'wp-hooks', 'wp-polyfill' ),
     472        'priority-queue'                     => array(),
    453473        'redux-routine'                      => array( 'wp-polyfill' ),
    454474        'rich-text'                          => array(
     
    468488        'api-fetch',
    469489        'blocks',
     490        'block-editor',
    470491        'block-library',
    471492        'components',
     
    529550                '       .use( wp.data.plugins.persistence, { storageKey: storageKey } )',
    530551                '       .use( wp.data.plugins.controls );',
     552                '   wp.data.plugins.persistence.__unstableMigrate( { storageKey: storageKey } );',
    531553                '} )();',
    532554            )
Note: See TracChangeset for help on using the changeset viewer.