WordPress.org

Make WordPress Core

Timestamp:
03/21/2019 04:55:21 AM (21 months ago)
Author:
tellyworth
Message:

General: Add sodium_compat library for crypto APIs in PHP < 7.2

This adds a pure PHP implementation of the cryptographic functions supported in PHP 7.2+. It provides the necessary backwards compatibility required to support signature verification and other security features going forward across all supported PHP versions.

Props paragoninitiativeenterprises
Fixes #45806. See #39309.

Location:
trunk/src/wp-includes/sodium_compat
Files:
4 added

Note: See TracChangeset for help on using the changeset viewer.