WordPress.org

Make WordPress Core

Changeset 46289


Ignore:
Timestamp:
09/25/2019 08:19:17 AM (3 months ago)
Author:
gziolo
Message:

Block Editor: Align the version of React with the one used in Gutenberg plugin

Gutenberg 6.5 works with react and react-dom set to v16.9.0. This change aligns both.

Props youknowriad.
Fixes #48121.

Location:
trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • trunk/package-lock.json

    r46255 r46289  
    1804518045        },
    1804618046        "react": {
    18047             "version": "16.8.4",
    18048             "resolved": "https://registry.npmjs.org/react/-/react-16.8.4.tgz",
    18049             "integrity": "sha512-0GQ6gFXfUH7aZcjGVymlPOASTuSjlQL4ZtVC5YKH+3JL6bBLCVO21DknzmaPlI90LN253ojj02nsapy+j7wIjg==",
     18047            "version": "16.9.0",
     18048            "resolved": "https://registry.npmjs.org/react/-/react-16.9.0.tgz",
     18049            "integrity": "sha512-+7LQnFBwkiw+BobzOF6N//BdoNw0ouwmSJTEm9cglOOmsg/TMiFHZLe2sEoN5M7LgJTj9oHH0gxklfnQe66S1w==",
    1805018050            "requires": {
    1805118051                "loose-envify": "^1.1.0",
    1805218052                "object-assign": "^4.1.1",
    18053                 "prop-types": "^15.6.2",
    18054                 "scheduler": "^0.13.4"
     18053                "prop-types": "^15.6.2"
    1805518054            }
    1805618055        },
     
    1809518094        },
    1809618095        "react-dom": {
    18097             "version": "16.8.4",
    18098             "resolved": "https://registry.npmjs.org/react-dom/-/react-dom-16.8.4.tgz",
    18099             "integrity": "sha512-Ob2wK7XG2tUDt7ps7LtLzGYYB6DXMCLj0G5fO6WeEICtT4/HdpOi7W/xLzZnR6RCG1tYza60nMdqtxzA8FaPJQ==",
     18096            "version": "16.9.0",
     18097            "resolved": "https://registry.npmjs.org/react-dom/-/react-dom-16.9.0.tgz",
     18098            "integrity": "sha512-YFT2rxO9hM70ewk9jq0y6sQk8cL02xm4+IzYBz75CQGlClQQ1Bxq0nhHF6OtSbit+AIahujJgb/CPRibFkMNJQ==",
    1810018099            "requires": {
    1810118100                "loose-envify": "^1.1.0",
    1810218101                "object-assign": "^4.1.1",
    1810318102                "prop-types": "^15.6.2",
    18104                 "scheduler": "^0.13.4"
     18103                "scheduler": "^0.15.0"
    1810518104            }
    1810618105        },
     
    1918419183        },
    1918519184        "scheduler": {
    19186             "version": "0.13.6",
    19187             "resolved": "https://registry.npmjs.org/scheduler/-/scheduler-0.13.6.tgz",
    19188             "integrity": "sha512-IWnObHt413ucAYKsD9J1QShUKkbKLQQHdxRyw73sw4FN26iWr3DY/H34xGPe4nmL1DwXyWmSWmMrA9TfQbE/XQ==",
     19185            "version": "0.15.0",
     19186            "resolved": "https://registry.npmjs.org/scheduler/-/scheduler-0.15.0.tgz",
     19187            "integrity": "sha512-xAefmSfN6jqAa7Kuq7LIJY0bwAPG3xlCj0HMEBQk1lxYiDKZscY2xJ5U/61ZTrYbmNQbXa+gc7czPkVo11tnCg==",
    1918919188            "requires": {
    1919019189                "loose-envify": "^1.1.0",
  • trunk/package.json

    r46189 r46289  
    115115        "moment": "2.22.2",
    116116        "polyfill-library": "3.27.4",
    117         "react": "16.8.4",
    118         "react-dom": "16.8.4",
     117        "react": "16.9.0",
     118        "react-dom": "16.9.0",
    119119        "twemoji": "12.1.2",
    120120        "underscore": "1.8.3",
  • trunk/src/wp-includes/script-loader.php

    r46257 r46289  
    9292
    9393    $vendor_scripts_versions = array(
    94         'react'                       => '16.8.4',
    95         'react-dom'                   => '16.8.4',
     94        'react'                       => '16.9.0',
     95        'react-dom'                   => '16.9.0',
    9696        'moment'                      => '2.22.2',
    9797        'lodash'                      => '4.17.15',
Note: See TracChangeset for help on using the changeset viewer.