WordPress.org

Make WordPress Core


Ignore:
Timestamp:
10/14/2019 05:33:34 PM (8 months ago)
Author:
whyisjake
Message:

Administration: Ensure that admin referer nonce is valid.

Coding standards, ensure that nonce is valid with identical, rather then equal operator.

Backports [46477] to the 5.2 branch.
Props vortfu, xknown, whyisjake.

Location:
branches/5.2
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • branches/5.2

  • branches/5.2/tests/phpunit/tests/auth.php

    r43571 r46486  
    2525        self::$user_id = self::$_user->ID;
    2626
    27         require_once( ABSPATH . WPINC . '/class-phpass.php' );
     27        require_once ABSPATH . WPINC . '/class-phpass.php';
    2828        self::$wp_hasher = new PasswordHash( 8, true );
    2929    }
     
    166166    }
    167167
     168    public function test_check_admin_referer_with_default_action_as_string_not_doing_it_wrong() {
     169        // A valid nonce needs to be set so the check doesn't die()
     170        $_REQUEST['_wpnonce'] = wp_create_nonce( '-1' );
     171        $result               = check_admin_referer( '-1' );
     172        $this->assertSame( 1, $result );
     173
     174        unset( $_REQUEST['_wpnonce'] );
     175    }
     176
    168177    /**
    169178     * @ticket 36361
Note: See TracChangeset for help on using the changeset viewer.