WordPress.org

Make WordPress Core


Ignore:
Timestamp:
05/24/2020 09:13:39 AM (17 months ago)
Author:
SergeyBiryukov
Message:

Coding Standards: Use strict comparison for $wp_db_version check in wp-admin/network/upgrade.php.

Follow-up to [47787], [47788].

See #50155, #49542.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/network/upgrade.php

    r47198 r47852  
    9191                )
    9292            );
     93
    9394            if ( is_wp_error( $response ) ) {
    9495                wp_die(
     
    110111             */
    111112            do_action( 'after_mu_upgrade', $response );
     113
    112114            /**
    113115             * Fires after each site has been upgraded.
     
    133135    case 'show':
    134136    default:
    135         if ( get_site_option( 'wpmu_upgrade_site' ) != $GLOBALS['wp_db_version'] ) :
     137        if ( (int) get_site_option( 'wpmu_upgrade_site' ) !== $GLOBALS['wp_db_version'] ) :
    136138            ?>
    137139        <h2><?php _e( 'Database Update Required' ); ?></h2>
Note: See TracChangeset for help on using the changeset viewer.