WordPress.org

Make WordPress Core

Changeset 48046 for trunk/.travis.yml


Ignore:
Timestamp:
06/15/2020 03:02:32 PM (6 months ago)
Author:
desrosj
Message:

Coding Standards: Remove the PHP Compatibility scanning job from the allowed_failures list.

All pre-existing compatibility warnings and errors as flagged by the PHPCompatibilityWP ruleset have been addressed.

Fixes #49922.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/.travis.yml

    r47905 r48046  
    3434  - env: WP_TRAVISCI=lint:php COMPOSER_INSTALL=true NPM_INSTALL=false WP_INSTALL=false
    3535    name: PHP Linting
     36  - env: WP_TRAVISCI=test:compat COMPOSER_INSTALL=true NPM_INSTALL=false WP_INSTALL=false
     37    name: "PHP Compatibility Check"
    3638  - env: WP_TRAVISCI=travis:js WP_INSTALL=false PUPPETEER_SKIP_CHROMIUM_DOWNLOAD=
    3739    name: JS Tests
    38   - env: WP_TRAVISCI=test:compat COMPOSER_INSTALL=true NPM_INSTALL=false WP_INSTALL=false
    39     name: "PHP Compatibility Check"
    4040  - env: LOCAL_PHP=7.4-fpm WP_TRAVISCI=test:php
    4141    name: "PHPUnit Tests: PHP 7.4"
     
    5555    name: "PHPUnit Tests: PHP 8.0"
    5656  allow_failures:
    57   - env: WP_TRAVISCI=test:compat COMPOSER_INSTALL=true NPM_INSTALL=false WP_INSTALL=false
    5857  - env: LOCAL_PHP=8.0-fpm WP_TRAVISCI=test:php
    5958  fast_finish: true
Note: See TracChangeset for help on using the changeset viewer.