WordPress.org

Make WordPress Core

Changeset 48530


Ignore:
Timestamp:
07/21/2020 12:56:40 PM (9 months ago)
Author:
SergeyBiryukov
Message:

Mail: Make sure the PHPMailer class is only required once if a plugin requires wp-includes/class-phpmailer.php directly.

Follow-up to [48033].

Props david.binda.
Fixes #50716. See #41750.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-includes/class-phpmailer.php

    r48035 r48530  
    1313}
    1414
    15 require __DIR__ . '/PHPMailer/PHPMailer.php';
    16 require __DIR__ . '/PHPMailer/Exception.php';
     15require_once __DIR__ . '/PHPMailer/PHPMailer.php';
     16require_once __DIR__ . '/PHPMailer/Exception.php';
    1717
    1818class_alias( PHPMailer\PHPMailer\PHPMailer::class, 'PHPMailer' );
Note: See TracChangeset for help on using the changeset viewer.