WordPress.org

Make WordPress Core

Changeset 49165


Ignore:
Timestamp:
10/15/2020 11:06:49 PM (6 weeks ago)
Author:
desrosj
Message:

External Libraries: Update React, ReactDOM and Lodash.

This updates:

  • react and react-dom from 16.9.0 to 16.13.1.
  • lodash from 4.17.15 to 4.17.19`.

Props isabel_brison.
Fixes #51505.

Location:
trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • trunk/package-lock.json

    r49135 r49165  
    1391113911            "dependencies": {
    1391213912                "debug": {
    13913                     "version": "4.1.1",
    13914                     "resolved": "https://registry.npmjs.org/debug/-/debug-4.1.1.tgz",
    13915                     "integrity": "sha512-pYAIzeRo8J6KPEaJ0VWOh5Pzkbw/RetuzehGM7QRRX5he4fPHx2rdKMB256ehJCkX+XRQm16eZLqLNS8RSZXZw==",
    13916                     "dev": true,
    13917                     "requires": {
    13918                         "ms": "^2.1.1"
     13913                    "version": "4.2.0",
     13914                    "resolved": "https://registry.npmjs.org/debug/-/debug-4.2.0.tgz",
     13915                    "integrity": "sha512-IX2ncY78vDTjZMFUdmsvIRFY2Cf4FnD0wRs+nQwJU8Lu99/tPFdb0VybiiMTPe3I6rQmwsqQqRBvxU+bZ/I8sg==",
     13916                    "dev": true,
     13917                    "requires": {
     13918                        "ms": "2.1.2"
    1391913919                    }
    1392013920                },
     
    2086520865            "dependencies": {
    2086620866                "debug": {
    20867                     "version": "4.1.1",
    20868                     "resolved": "https://registry.npmjs.org/debug/-/debug-4.1.1.tgz",
    20869                     "integrity": "sha512-pYAIzeRo8J6KPEaJ0VWOh5Pzkbw/RetuzehGM7QRRX5he4fPHx2rdKMB256ehJCkX+XRQm16eZLqLNS8RSZXZw==",
    20870                     "dev": true,
    20871                     "requires": {
    20872                         "ms": "^2.1.1"
     20867                    "version": "4.2.0",
     20868                    "resolved": "https://registry.npmjs.org/debug/-/debug-4.2.0.tgz",
     20869                    "integrity": "sha512-IX2ncY78vDTjZMFUdmsvIRFY2Cf4FnD0wRs+nQwJU8Lu99/tPFdb0VybiiMTPe3I6rQmwsqQqRBvxU+bZ/I8sg==",
     20870                    "dev": true,
     20871                    "requires": {
     20872                        "ms": "2.1.2"
    2087320873                    }
    2087420874                },
     
    2109421094        },
    2109521095        "react": {
    21096             "version": "16.9.0",
    21097             "resolved": "https://registry.npmjs.org/react/-/react-16.9.0.tgz",
    21098             "integrity": "sha512-+7LQnFBwkiw+BobzOF6N//BdoNw0ouwmSJTEm9cglOOmsg/TMiFHZLe2sEoN5M7LgJTj9oHH0gxklfnQe66S1w==",
     21096            "version": "16.13.1",
     21097            "resolved": "https://registry.npmjs.org/react/-/react-16.13.1.tgz",
     21098            "integrity": "sha512-YMZQQq32xHLX0bz5Mnibv1/LHb3Sqzngu7xstSM+vrkE5Kzr9xE0yMByK5kMoTK30YVJE61WfbxIFFvfeDKT1w==",
    2109921099            "requires": {
    2110021100                "loose-envify": "^1.1.0",
     
    2114321143        },
    2114421144        "react-dom": {
    21145             "version": "16.9.0",
    21146             "resolved": "https://registry.npmjs.org/react-dom/-/react-dom-16.9.0.tgz",
    21147             "integrity": "sha512-YFT2rxO9hM70ewk9jq0y6sQk8cL02xm4+IzYBz75CQGlClQQ1Bxq0nhHF6OtSbit+AIahujJgb/CPRibFkMNJQ==",
     21145            "version": "16.13.1",
     21146            "resolved": "https://registry.npmjs.org/react-dom/-/react-dom-16.13.1.tgz",
     21147            "integrity": "sha512-81PIMmVLnCNLO/fFOQxdQkvEq/+Hfpv24XNJfpyZhTRfO0QcmQIF/PgCa1zCOj2w1hrn12MFLyaJ/G0+Mxtfag==",
    2114821148            "requires": {
    2114921149                "loose-envify": "^1.1.0",
    2115021150                "object-assign": "^4.1.1",
    2115121151                "prop-types": "^15.6.2",
    21152                 "scheduler": "^0.15.0"
     21152                "scheduler": "^0.19.1"
    2115321153            }
    2115421154        },
     
    2261922619        },
    2262022620        "scheduler": {
    22621             "version": "0.15.0",
    22622             "resolved": "https://registry.npmjs.org/scheduler/-/scheduler-0.15.0.tgz",
    22623             "integrity": "sha512-xAefmSfN6jqAa7Kuq7LIJY0bwAPG3xlCj0HMEBQk1lxYiDKZscY2xJ5U/61ZTrYbmNQbXa+gc7czPkVo11tnCg==",
     22621            "version": "0.19.1",
     22622            "resolved": "https://registry.npmjs.org/scheduler/-/scheduler-0.19.1.tgz",
     22623            "integrity": "sha512-n/zwRWRYSUj0/3g/otKDRPMh6qv2SYMWNq85IEa8iZyAv8od9zDYpGSnpBEjNgcMNq6Scbu5KfIPxNF72R/2EA==",
    2262422624            "requires": {
    2262522625                "loose-envify": "^1.1.0",
     
    2520125201                },
    2520225202                "tar-stream": {
    25203                     "version": "2.1.3",
    25204                     "resolved": "https://registry.npmjs.org/tar-stream/-/tar-stream-2.1.3.tgz",
    25205                     "integrity": "sha512-Z9yri56Dih8IaK8gncVPx4Wqt86NDmQTSh49XLZgjWpGZL9GK9HKParS2scqHCC4w6X9Gh2jwaU45V47XTKwVA==",
    25206                     "dev": true,
    25207                     "requires": {
    25208                         "bl": "^4.0.1",
     25203                    "version": "2.1.4",
     25204                    "resolved": "https://registry.npmjs.org/tar-stream/-/tar-stream-2.1.4.tgz",
     25205                    "integrity": "sha512-o3pS2zlG4gxr67GmFYBLlq+dM8gyRGUOvsrHclSkvtVtQbjV0s/+ZE8OpICbaj8clrX3tjeHngYGP7rweaBnuw==",
     25206                    "dev": true,
     25207                    "requires": {
     25208                        "bl": "^4.0.3",
    2520925209                        "end-of-stream": "^1.4.1",
    2521025210                        "fs-constants": "^1.0.0",
  • trunk/package.json

    r49135 r49165  
    141141        "moment": "2.27.0",
    142142        "polyfill-library": "3.42.0",
    143         "react": "16.9.0",
    144         "react-dom": "16.9.0",
     143        "react": "16.13.1",
     144        "react-dom": "16.13.1",
    145145        "twemoji": "13.0.0",
    146146        "underscore": "1.8.3",
  • trunk/src/wp-includes/script-loader.php

    r49154 r49165  
    9595
    9696    $vendor_scripts_versions = array(
    97         'react'                       => '16.9.0',
    98         'react-dom'                   => '16.9.0',
     97        'react'                       => '16.13.1',
     98        'react-dom'                   => '16.13.1',
    9999        'moment'                      => '2.26.0',
    100         'lodash'                      => '4.17.15',
     100        'lodash'                      => '4.17.19',
    101101        'wp-polyfill-fetch'           => '3.0.0',
    102102        'wp-polyfill-formdata'        => '3.0.12',
Note: See TracChangeset for help on using the changeset viewer.