WordPress.org

Make WordPress Core

Changeset 492 in tests


Ignore:
Timestamp:
12/28/11 12:30:41 (2 years ago)
Author:
westi
Message:

With PHPMailer 5.2 the hacks are no longer needed to make it testable as equivalent changes have been includes upstream.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • wp-testlib/mock-mailer.php

    r358 r492  
    11<?php 
    22 
    3 if ( version_compare( $GLOBALS['wp_version'], '3.1.9', '>' ) ) { 
    4     echo "Using custom build of PHPMailer for 3.2 and later testing\n\n"; 
     3if ( version_compare( $GLOBALS['wp_version'], '3.1.9', '>' ) && version_compare( $GLOBALS['wp_version'], '3.3.9', '<' ) ) { 
     4    echo "Using custom build of PHPMailer for 3.2 and 3.3 testing\n\n"; 
    55    require_once(DIR_TESTROOT . '/wp-testlib/class-phpmailer.php'); 
    66} else { 
Note: See TracChangeset for help on using the changeset viewer.