Make WordPress Core

Changeset 49306


Ignore:
Timestamp:
10/25/2020 01:12:13 AM (2 years ago)
Author:
TimothyBlynJacobs
Message:

Build Tools: Fix running installing composer dependencies using composer 2.0.

This updates the dealerdirect/phpcodesniffer-composer-installer package to allow installing version 0.7.0 which supports composer 2.0.

Props itowhid06, jrf.
Fixes #51624.

Location:
trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/composer.json

    r49037 r49306  
    1414    },
    1515    "require-dev": {
    16         "dealerdirect/phpcodesniffer-composer-installer": "~0.6.0",
     16        "dealerdirect/phpcodesniffer-composer-installer": "^0.6.2 || ^0.7.0",
    1717        "wp-coding-standards/wpcs": "~2.3.0",
    1818        "phpcompatibility/phpcompatibility-wp": "^2.1.0",
  • trunk/composer.lock

    r48957 r49306  
    55        "This file is @generated automatically"
    66    ],
    7     "content-hash": "798cd84a945e4caa3d0161ff63ec3743",
     7    "content-hash": "463db2b4afb439fb63d93173c0852e27",
    88    "packages": [],
    99    "packages-dev": [
    1010        {
    1111            "name": "dealerdirect/phpcodesniffer-composer-installer",
    12             "version": "v0.6.2",
     12            "version": "v0.7.0",
    1313            "source": {
    1414                "type": "git",
    1515                "url": "https://github.com/Dealerdirect/phpcodesniffer-composer-installer.git",
    16                 "reference": "8001af8eb107fbfcedc31a8b51e20b07d85b457a"
    17             },
    18             "dist": {
    19                 "type": "zip",
    20                 "url": "https://api.github.com/repos/Dealerdirect/phpcodesniffer-composer-installer/zipball/8001af8eb107fbfcedc31a8b51e20b07d85b457a",
    21                 "reference": "8001af8eb107fbfcedc31a8b51e20b07d85b457a",
    22                 "shasum": ""
    23             },
    24             "require": {
    25                 "composer-plugin-api": "^1.0",
    26                 "php": "^5.3|^7",
    27                 "squizlabs/php_codesniffer": "^2|^3"
     16                "reference": "e8d808670b8f882188368faaf1144448c169c0b7"
     17            },
     18            "dist": {
     19                "type": "zip",
     20                "url": "https://api.github.com/repos/Dealerdirect/phpcodesniffer-composer-installer/zipball/e8d808670b8f882188368faaf1144448c169c0b7",
     21                "reference": "e8d808670b8f882188368faaf1144448c169c0b7",
     22                "shasum": ""
     23            },
     24            "require": {
     25                "composer-plugin-api": "^1.0 || ^2.0",
     26                "php": ">=5.3",
     27                "squizlabs/php_codesniffer": "^2 || ^3 || 4.0.x-dev"
    2828            },
    2929            "require-dev": {
     
    7272                "tests"
    7373            ],
    74             "time": "2020-01-29T20:22:20+00:00"
     74            "support": {
     75                "issues": "https://github.com/dealerdirect/phpcodesniffer-composer-installer/issues",
     76                "source": "https://github.com/dealerdirect/phpcodesniffer-composer-installer"
     77            },
     78            "time": "2020-06-25T14:57:39+00:00"
    7579        },
    7680        {
Note: See TracChangeset for help on using the changeset viewer.