WordPress.org

Make WordPress Core

Changeset 4984


Ignore:
Timestamp:
03/07/2007 04:16:06 AM (13 years ago)
Author:
ryan
Message:

Make sure openssl is available. Props Robert Deaton and rob1n. fixes #3765

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/wp-includes/cron.php

    r4980 r4984  
    8787    if ($parts['scheme'] == 'https') {
    8888        // support for SSL was added in 4.3.0
    89         if (version_compare(phpversion(), '4.3.0', '>=')) {
     89        if (version_compare(phpversion(), '4.3.0', '>=') && function_exists('openssl_open')) {
    9090            $argyle = @fsockopen('ssl://' . $parts['host'], $_SERVER['SERVER_PORT'], $errno, $errstr, 0.01);
    9191        } else {
Note: See TracChangeset for help on using the changeset viewer.